summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoréclairevoyant2023-02-10 01:40:59 -0500
committeréclairevoyant2023-02-10 01:40:59 -0500
commita6e849c134ee2d9f1357522c37fac9cdc9a109fa (patch)
treeb2e2f5a5b85a526d8bc8e60e750c44b0bb366c9a /PKGBUILD
parent3682ba494a79cf9a160a60b7575a2f9278b84d03 (diff)
downloadaur-systemd-bootchart-git.tar.gz
systemd-bootchart-git: update makedeps, fix versioning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 20 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5b4ac84f2c2..66759c3a62ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,43 @@
-# Contributor: Dave Reisner <d@falconindy.com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: éclairevoyant
+# Contributor: Dave Reisner <d at falconindy dot com>
+# Contributor: Stefan Husmann <stefan-husmann at t-online dot de>
pkgname=systemd-bootchart-git
-pkgver=r54.ef042f6
+pkgver=234.r2.ef042f6
pkgrel=1
pkgdesc="Boot performance graphing tool"
arch=('i686' 'x86_64')
url="https://github.com/systemd/systemd-bootchart"
license=('LGPL2.1')
depends=('libsystemd.so')
-makedepends=('git' 'intltool')
+makedepends=('docbook-xsl' 'git' 'intltool' 'libxslt')
provides=('systemd-bootchart')
conflicts=('systemd-bootchart' 'systemd<=229')
-source=("git+https://github.com/systemd/systemd-bootchart")
-md5sums=('SKIP')
+source=("git+$url.git")
+b2sums=('SKIP')
backup=('etc/systemd/bootchart.conf')
pkgver() {
- cd "systemd-bootchart"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "systemd-bootchart"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {
- cd "systemd-bootchart"
-
- ./autogen.sh
+ cd "systemd-bootchart"
+ ./autogen.sh
}
build() {
- cd "systemd-bootchart"
-
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib \
- --libdir=/usr/lib
-
- make
+ cd "systemd-bootchart"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --libdir=/usr/lib
+ make
}
package() {
- cd "systemd-bootchart"
-
- make DESTDIR="$pkgdir" install
+ cd "systemd-bootchart"
+ make DESTDIR="$pkgdir" install
}