summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDave Reisner2016-05-22 04:11:38 -0400
committerDave Reisner2016-05-22 04:20:11 -0400
commit29f498e69b6c777668c3e081bf33ec0e0bbc812f (patch)
tree73f34d84be096f02dcaecce30ff5307d587e10d5 /PKGBUILD
downloadaur-29f498e69b6c777668c3e081bf33ec0e0bbc812f.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3a07fa1beab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: Dave Reisner <d@falconindy.com>
+
+pkgname=systemd-bootchart-git
+pkgver=r1.e6c5e46
+pkgrel=1
+pkgdesc="Boot performance graphing tool"
+arch=('i686' 'x86_64')
+url="https://github.com/systemd/systemd-bootchart"
+license=('LGPL2.1')
+depends=('libsystemd.so')
+makedepends=('git')
+provides=('systemd-bootchart')
+conflicts=('systemd-bootchart' 'systemd<=229')
+source=("git://github.com/systemd/systemd-bootchart")
+backup=('etc/systemd/bootchart.conf')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "systemd-bootchart"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "systemd-bootchart"
+
+ # https://github.com/systemd/systemd-bootchart/issues/4
+ sed -i '/LIBSYSTEMD_JOURNAL/ s/libsystemd-journal/libsystemd/' configure.ac
+
+ ./autogen.sh
+}
+
+build() {
+ cd "systemd-bootchart"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --libdir=/usr/lib
+
+ make
+}
+
+package() {
+ cd "systemd-bootchart"
+
+ make DESTDIR="$pkgdir" install
+
+ # https://github.com/systemd/systemd-bootchart/issues/5
+ mv "$pkgdir/lib" "$pkgdir/usr/lib"
+}