summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Stepanov2015-12-11 01:10:04 +0300
committerKonstantin Stepanov2015-12-11 01:10:12 +0300
commitc215e92626757aeb7b0dd23fc1a3cb3fe41e710a (patch)
tree4b537d6bc78636b64dc6b2d3e304b60c7b192192 /PKGBUILD
parentaa4177a7652d86f1556e7a4b33db9e6a33f91011 (diff)
downloadaur-c215e92626757aeb7b0dd23fc1a3cb3fe41e710a.tar.gz
update to version v1.0.0-rc2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a7e62632a2b..51be8bacf8c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Konstantin Stepanov <me@kstep.me>
pkgname=systemd-cron-next
-pkgver=1.0.0.rc1
-pkgrel=3
+pkgver=1.0.0.rc2
+_gitver=1.0.0-rc2
+pkgrel=1
pkgdesc="systemd generator to generate timers/services from crontab and anacrontab files"
url="https://github.com/systemd-cron/systemd-cron-next"
arch=('any')
@@ -10,11 +11,11 @@ depends=('systemd')
makedepends=('rust')
provides=('cron' 'anacron')
replaces=('cron' 'anacron')
-source=('https://github.com/systemd-cron/systemd-cron-next/archive/v1.0.0-rc1.zip')
-md5sums=('a7d5415795cd166d258f72e5cebcfaee')
+source=("https://github.com/systemd-cron/systemd-cron-next/archive/v${_gitver}.zip")
+md5sums=('2784d761ddd1e0a2ebcca48984281145')
build() {
- cd "$srcdir/systemd-cron-next-1.0.0-rc1"
+ cd "${srcdir}/${pkgname}-${_gitver}"
if which multirust; then
multirust override stable
fi
@@ -23,7 +24,6 @@ build() {
}
package() {
- cd "$srcdir/systemd-cron-next-1.0.0-rc1"
- sed -i -e 's/^install: build$/install:/' Makefile
+ cd "${srcdir}/${pkgname}-${_gitver}"
make install
}