summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Stepanov2015-07-06 02:45:56 +0300
committerKonstantin Stepanov2015-07-06 02:47:36 +0300
commit9c53dec0a8c4c9cbc002a4023bfeed42baf9a7f5 (patch)
treebe91b4bafc65960de0a0f2b4319ccc10b406d1d0 /PKGBUILD
parente3857f34c0bb79f2276ab2df7b748f0f6e1a631e (diff)
downloadaur-systemd-crontab-generator.tar.gz
update to version 0.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 35 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c2b3f4bfaee..06334a0371c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,60 @@
# Maintainer: Konstantin Stepanov <me@kstep.me>
pkgname=systemd-crontab-generator
-pkgver=0.8
+pkgver=0.9.0
pkgrel=1
pkgdesc="systemd generator to generate timers/services from crontab and anacrontab files"
-url="https://github.com/kstep/systemd-crontab-generator"
-arch=('any')
+url="https://github.com/systemd-cron/systemd-crontab-generator"
+arch=('i686' 'x86_64')
license=('GPL3')
depends=('python2' 'systemd')
+makedepends=('rust')
provides=('cron' 'anacron')
replaces=('cron' 'anacron')
-source=(systemd-crontab-generator
- systemd-crontab-update
- cron.target
- crontab
- systemd-crontab-generator.1
- crontab.1
- crontab.5)
-md5sums=('3e6e2fb5bf3a6f05cacfbbb113516026'
+source=('https://github.com/systemd-cron/systemd-crontab-generator/archive/master.zip'
+ 'systemd-crontab-update'
+ 'crontab'
+ 'systemd-crontab-generator.1'
+ 'crontab.1'
+ 'crontab.5')
+md5sums=('35e308952f6e4f7d80c50d83ba981c2a'
'6f00710ad710e319b52edef3e98bd010'
- '97450f27b69a1e88f1b21faad403df7c'
'4ac2cfc8de6dabf2e08f39b3c3557879'
'15acf6fd2a9533c13ce21c6e03210194'
'd863925d682395cef72701725f180884'
'f5e92c03bcb37acd580e2e27f5facc6a')
+prepare() {
+ RUSTVER=$(rustc --version | awk '{ print $2 }')
+ if [[ -n "$RUSTVER" && ("$RUSTVER" < "1.3.0") ]]; then
+ error "Rust nightly is required to build this package."
+ error "Possible ways to get Rust nightly:"
+ error " - AUR package 'rust-nightly-bin',"
+ error " - AUR package 'multirust', and then choose"
+ error " nightly channel with 'multirust default nightly' command,"
+ error " - from official site: http://www.rust-lang.org/install.html."
+ return 1
+ fi
+}
+
build() {
- echo
+ cd "$srcdir/systemd-crontab-generator-master"
+ make release
}
package() {
- install --mode=0755 -D systemd-crontab-generator ${pkgdir}/usr/lib/systemd/system-generators/systemd-crontab-generator
+ cd "$srcdir/systemd-crontab-generator-master"
+ make install PREFIX="$pkgdir/usr"
+
+ cd "$srcdir/"
install --mode=0644 -D systemd-crontab-generator.1 ${pkgdir}/usr/share/man/man1/systemd-crontab-generator.1
gzip ${pkgdir}/usr/share/man/man1/systemd-crontab-generator.1
- install --mode=0755 -D systemd-crontab-update ${pkgdir}/usr/bin/systemd-crontab-update
- install --mode=0644 -D cron.target ${pkgdir}/usr/lib/systemd/system/cron.target
- install --mode=0755 -D crontab ${pkgdir}/usr/bin/crontab
+
install --mode=0644 -D crontab.1 ${pkgdir}/usr/share/man/man1/crontab.1
gzip ${pkgdir}/usr/share/man/man1/crontab.1
+
install --mode=0644 -D crontab.5 ${pkgdir}/usr/share/man/man5/crontab.5
gzip ${pkgdir}/usr/share/man/man5/crontab.5
+
+ install --mode=0755 -D systemd-crontab-update ${pkgdir}/usr/bin/systemd-crontab-update
+ install --mode=0755 -D crontab ${pkgdir}/usr/bin/crontab
}