summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2022-06-03 08:03:25 +0300
committerYurii Kolesnykov2022-06-03 08:03:25 +0300
commit2e4d36265b1737d92ea4757c88e416347a6f7790 (patch)
tree6f84de25e0fe8f7e81b7b93c8a792e1f8dcbd73e /PKGBUILD
parentec3af242e89fcefeed84949539e4b9684eac6151 (diff)
downloadaur-2e4d36265b1737d92ea4757c88e416347a6f7790.tar.gz
fix pkgver
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8c999b7afcc..639d27097a9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgbase=systemd
pkgbase=$_pkgbase-git
pkgname=('systemd-git' 'systemd-libs-git' 'systemd-resolvconf-git' 'systemd-sysvcompat-git')
pkgdesc='systemd (git version)'
-pkgver=251.r65.g620ecc9c4b
+pkgver=251.r58161.311f57a402
pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
@@ -15,7 +15,6 @@ makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
'python-jinja' 'python-lxml' 'quota-tools' 'shadow' 'gnu-efi-libs' 'git'
'meson' 'libseccomp' 'pcre2' 'audit' 'kexec-tools' 'libxkbcommon'
'bash-completion' 'p11-kit' 'systemd' 'libfido2' 'tpm2-tss' 'rsync')
-options=(!ccache)
source=('git+https://github.com/systemd/systemd'
'0001-Use-Arch-Linux-device-access-groups.patch'
'initcpio-hook-udev'
@@ -54,6 +53,13 @@ sha512sums=('SKIP'
'da7a97d5d3701c70dd5388b0440da39006ee4991ce174777931fea2aa8c90846a622b2b911f02ae4d5fffb92680d9a7e211c308f0f99c04896278e2ee0d9a4dc'
'a50d202a9c2e91a4450b45c227b295e1840cc99a5e545715d69c8af789ea3dd95a03a30f050d52855cabdc9183d4688c1b534eaa755ebe93616f9d192a855ee3'
'825b9dd0167c072ba62cabe0677e7cd20f2b4b850328022540f122689d8b25315005fa98ce867cf6e7460b2b26df16b88bb3b5c9ebf721746dce4e2271af7b97')
+
+pkgver() {
+ cd "$_pkgbase"
+ local _major=`grep -m1 version meson.build | cut -d\' -f2`
+ printf "%s.r%s.%s" "${_major}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
cd "$_pkgbase"
@@ -61,11 +67,6 @@ prepare() {
patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
}
-pkgver() {
- cd "$_pkgbase"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
build() {
local _timeservers=({0..3}.arch.pool.ntp.org)
local _nameservers=(
@@ -82,10 +83,6 @@ build() {
)
local _meson_options=(
- # internal version comparison is incompatible with pacman:
- # 249~rc1 < 249 < 249.1 < 249rc
- -Dversion-tag="${pkgver/-/\~}-${pkgrel}-arch"
- -Dshared-lib-tag="${pkgver/-/\~}-${pkgrel}-arch"
-Dmode=release
-Dgnu-efi=true