summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2022-01-07 00:37:31 +0300
committerYurii Kolesnykov2022-01-07 00:37:31 +0300
commitac4a9794ab09f6963549dd32992549cbe40ee4c9 (patch)
tree8e7c673cdbb8576b0873e43ea49e035384836eb4 /PKGBUILD
parent2940a9cfebda8d19fac977c1709bf477b458f4e4 (diff)
downloadaur-ac4a9794ab09f6963549dd32992549cbe40ee4c9.tar.gz
250
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8c55fcd2d58..b4be7506221b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
-# Based on core/systemd by:
+# Based on testing/systemd by:
# Maintainer: Christian Hesse <mail@eworm.de>
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Maintainer: Tom Gundersen <teg@jklm.no>
@@ -8,7 +8,7 @@ _pkgbase=systemd
pkgbase=$_pkgbase-git
pkgname=('systemd-git' 'systemd-libs-git' 'systemd-resolvconf-git' 'systemd-sysvcompat-git')
pkgdesc='systemd (git version)'
-pkgver=250.rc2.r55.g17cfd6f96f
+pkgver=250.r192.gcd933f14bd
pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
@@ -21,7 +21,6 @@ makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
options=('!ccache')
source=('git+https://github.com/systemd/systemd'
'0001-Use-Arch-Linux-device-access-groups.patch'
- '0003-PARTIAL-REVERT-commit-tree-wide-replace-strverscmp-and-str_verscmp-with-strverscmp_improved.patch'
'initcpio-hook-udev'
'initcpio-install-systemd'
'initcpio-install-udev'
@@ -40,8 +39,7 @@ source=('git+https://github.com/systemd/systemd'
'30-systemd-udev-reload.hook'
'30-systemd-update.hook')
sha512sums=('SKIP'
- '10f3b477527ec263cc6465c84d94416e356435930edc9e26844a0fd4f71e87a27fa0f91ce24b43a22cacdd2ead5e760e9d607369bc537a8da8d34021302a89a1'
- '34541f1967536524329867f9f341f8d9250d9d771c60dc3e6a22ccb82fc01f103cfd3f9903329777591ccbecd2446622a5d6b3804fa0411482b85c70593ee8ad'
+ 'cc0c2ffb5f7c3a7176cd68f3dddd85ca000dcc4cdf3044746a20147234adb6811800fd28a4713faa6a59bf8c02be9fd43c2d6aa6695fd1dbf03ae773a91d090c'
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
'5479c8ef963ff247381392907c13308b4ae3a9383c867bd4c8a318b159f23acdb4be5f4ddae0dab4665f4927d3f30166077b1d3aaa2cde6bf53d023b7abb939c'
'a8c7e4a2cc9c9987e3c957a1fc3afe8281f2281fffd2e890913dcf00cf704024fb80d86cb75f9314b99b0e03bac275b22de93307bfc226d8be9435497e95b7e6'
@@ -64,10 +62,6 @@ prepare() {
# Replace cdrom/dialout/tape groups with optical/uucp/storage
patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
-
- # https://bugs.archlinux.org/task/70264
- # https://github.com/systemd/systemd/issues/19191
- patch -Np1 -i ../0003-PARTIAL-REVERT-commit-tree-wide-replace-strverscmp-and-str_verscmp-with-strverscmp_improved.patch
}
pkgver() {
@@ -197,9 +191,6 @@ package_systemd-git() {
sed -i -e '/^C \/etc\/nsswitch\.conf/d' \
-e '/^C \/etc\/issue/d' "$pkgdir"/usr/lib/tmpfiles.d/etc.conf
- # add back tmpfiles.d/legacy.conf, normally omitted without sysv-compat
- # install -m0644 "$_pkgbase"/tmpfiles.d/legacy.conf "$pkgdir"/usr/lib/tmpfiles.d
-
# ship default policy to leave services disabled
echo 'disable *' >"$pkgdir"/usr/lib/systemd/system-preset/99-default.preset