summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRanieri Althoff2019-12-02 18:55:17 -0300
committerRanieri Althoff2019-12-02 18:56:34 -0300
commit040d254195a1c4248ddb0b67b1e6a14efef86819 (patch)
tree9d9182dbf29f07e6b38df105d55812bfb0087b37 /PKGBUILD
parent496169501306a8c9f0c235645faf08146aeb415c (diff)
downloadaur-040d254195a1c4248ddb0b67b1e6a14efef86819.tar.gz
systemd-light 244-1
- added toggle for hibernation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 9 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8e5b91360a0..d965fdd98b0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,9 +33,9 @@ pkgbase=systemd-light
_pkgbase=${pkgbase%-light}
pkgname=('systemd-light' 'systemd-light-libs')
# Can be from either systemd or systemd-stable
-_commit='e51d9bf9e5ac5a6618c175cd9b5cfdc6733cd5d1'
-pkgver=243.162
-pkgrel=2
+_tag='ec298e702b87e2859f7f7864f51eef3360daf163' # git rev-parse v${pkgver}
+pkgver=244
+pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
makedepends=('acl' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
@@ -47,8 +47,7 @@ makedepends=('acl' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
options=('strip')
validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <lennart@poettering.net>
'5C251B5FC54EB2F80F407AAAC54CA336CFEB557E') # Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
-source=(# fragment is latest tag for source verification, final merge in prepare()
- "git+https://github.com/systemd/systemd-stable#tag=v${pkgver%.*}?signed"
+source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
"git+https://github.com/systemd/systemd#tag=v${pkgver%.*}?signed"
'0001-Use-Arch-Linux-device-access-groups.patch'
'initcpio-hook-udev'
@@ -70,7 +69,7 @@ source=(# fragment is latest tag for source verification, final merge in prepare
'30-systemd-update.hook')
sha512sums=('SKIP'
'SKIP'
- '9348683829190628e25b7b3300fd880c426d555bde330d5fc5150a9a54b3ad9d4d1f2e69ea1dc6d6f086693dacc53c5af30f1fa7ad9b479791fd77bcdafa430e'
+ 'e38c7c422c82953f9c2476a5ab8009d614cbec839e4088bff5db7698ddc84e3d8ed64f32ed323f57b1913c5c9703546f794996cb415ed7cdda930b627962a3c4'
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
'01de24951a05d38eca6b615a7645beb3677ca0e0f87638d133649f6dc14dcd2ea82594a60b793c31b14493a286d1d11a0d25617f54dbfa02be237652c8faa691'
'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
@@ -159,9 +158,6 @@ prepare() {
# add upstream repository for cherry-picking
git remote add -f upstream ../systemd
- # merge the latest stable commit (fast-foward only to make sure
- # the verified tag is in)
- git merge --ff-only "${_commit}"
local _c
for _c in "${_backports[@]}"; do
@@ -183,15 +179,6 @@ prepare() {
patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
}
-pkgver() {
- cd "$_pkgbase-stable"
-
- local _version _count
- _version="$(git describe --abbrev=0 --tags)"
- _count="$(git rev-list --count ${_version}..)"
- printf '%s.%s' "${_version#v}" "${_count}"
-}
-
build() {
local _timeservers=({0..3}.arch.pool.ntp.org)
local _nameservers=(
@@ -218,9 +205,10 @@ build() {
-Ddbuspolicydir=/usr/share/dbus-1/system.d
-Ddefault-hierarchy=hybrid
- -Ddefault-locale=C
-Ddefault-kill-user-processes=false
+ -Ddefault-locale=C
-Dfallback-hostname='archlinux'
+ -Dnologin-path=/usr/bin/nologin
-Dntp-servers="${_timeservers[*]}"
-Ddns-servers="${_nameservers[*]}"
-Drpmmacrosdir=no
@@ -231,6 +219,7 @@ build() {
-Dbacklight=$(is_systemd "$_backlight")
-Defi=$(is_systemd "$_bootloader")
-Dgnu-efi=$(is_systemd "$_bootloader")
+ -Dhibernate=$(is_nonempty "$_hibernate")
-Dlibcryptsetup=$(is_nonempty "$_cryptsetup")
-Dnetworkd=$(is_systemd "$_network")
-Dnss-mymachines=$(bool_opt 'machined' "${_features[@]}")
@@ -239,6 +228,7 @@ build() {
-Dresolve=$(is_systemd "$_resolver")
-Dtimedated=$(is_systemd "$_timesync")
-Dtimesyncd=$(is_systemd "$_timesync")
+ -Dzlib=$(bool_opt 'importd' "${_features[@]}")
)
for opt in hostnamed localed machined portabled firstboot importd rfkill; do