summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2021-05-27 19:43:18 +0200
committerHugo Osvaldo Barrera2021-05-27 19:43:18 +0200
commit7c680299587c8be11b461fd4742337213655ede3 (patch)
treead093cbfd65ff75fc437d6cb619266d764c38dbb /PKGBUILD
parent6c89ffde5a8dc935a1629929f0258c8d8d68c17a (diff)
downloadaur-7c680299587c8be11b461fd4742337213655ede3.tar.gz
Update to 2.0.0
And validate gpg signatures.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50e0850095dd..248237c37769 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
pkgname=systemd-lock-handler
-pkgver=1.1.0
+pkgver=2.0.0
pkgrel=1
pkgdesc="Logind lock event to systemd target translation."
arch=('any')
-url="https://gitlab.com/WhyNotHugo/systemd-lock-handler"
+url="https://git.sr.ht/~whynothugo/systemd-lock-handler"
license=('ISC')
-depends=('python-txdbus')
-source=("https://gitlab.com/WhyNotHugo/systemd-lock-handler/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
-md5sums=('3cda34d63b29cbb52442f80c40fa27f7')
+depends=('go')
+source=("git+https://git.sr.ht/~whynothugo/systemd-lock-handler?signed#tag=v${pkgver}")
+md5sums=('SKIP')
+validpgpkeys=('951082781CA308E4A529DEFD6F9FFF122B98C0CD')
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ make build
+}
package() {
- cd "$srcdir/$pkgname-v$pkgver"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" install
}