summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-04 02:04:30 +0000
committerJoão Figueiredo2021-02-04 02:04:30 +0000
commit0906964c79f39820ba7985c89bc44e8a2a580b5a (patch)
tree1b3924d05f68f467299e278a065a32464d79d349 /PKGBUILD
downloadaur-systemd-plasmoid.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..405a911d59f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
+
+pkgname=systemd-plasmoid
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="A plasma widget to control systemd services"
+arch=($CARCH)
+url="https://github.com/jansenm/systemd-plasmoid"
+license=(LGPL)
+depends=(qt5-declarative)
+makedepends=(extra-cmake-modules ki18n knotifications plasma-framework qt5-base)
+source=("$pkgname-$pkgver::$url/archive/$pkgver.tar.gz")
+sha256sums=('c1a15cc1119d50f86cb9012f575c293766472d737863f91d56e961f2d24218af')
+
+build() {
+ cmake -B build -S $pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}