summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2015-11-30 18:40:58 +0100
committerNicolas Iooss2015-11-30 18:40:58 +0100
commit1e37be109a72f09708f6e3420c74dbb44dc3e6f8 (patch)
treea1555755b1763f00cada4587c7796369b031e758 /PKGBUILD
parent2017367982b686362318da548c2c6adecc1bfc27 (diff)
downloadaur-1e37be109a72f09708f6e3420c74dbb44dc3e6f8.tar.gz
systemd-selinux 228-3 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e0e76031924..7b240750aa2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@
pkgbase=systemd-selinux
pkgname=('systemd-selinux' 'libsystemd-selinux' 'systemd-sysvcompat-selinux')
-pkgver=227
-pkgrel=1
+pkgver=228
+pkgrel=3
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
groups=('selinux')
-makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam-selinux'
+makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam-selinux' 'libelf'
'intltool' 'iptables' 'kmod' 'libcap' 'libidn' 'libgcrypt'
'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers'
'python-lxml' 'quota-tools' 'shadow-selinux' 'gnu-efi-libs' 'git'
@@ -37,6 +37,16 @@ md5sums=('SKIP'
prepare() {
cd "${pkgbase/-selinux}"
+ # sd-ndisc: drop RA packets from non-link-local addresses
+ # https://github.com/systemd/systemd/commit/3ccd31635353
+ # https://github.com/systemd/systemd/issues/1866
+ git cherry-pick -n 3ccd31635353
+
+ # networkd: link - do not drop config for loopback device
+ # https://github.com/systemd/systemd/commit/e5d44b34cca3
+ # https://github.com/systemd/systemd/issues/2023
+ git cherry-pick -n e5d44b34cca3
+
./autogen.sh
}
@@ -66,7 +76,7 @@ package_systemd-selinux() {
pkgdesc="system and service manager with SELinux support"
license=('GPL2' 'LGPL2.1')
depends=('acl' 'bash' 'dbus' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
- 'libgcrypt' 'libsystemd-selinux' 'libidn' 'lz4' 'pam-selinux' 'libseccomp'
+ 'libgcrypt' 'libsystemd-selinux' 'libidn' 'lz4' 'pam-selinux' 'libelf' 'libseccomp'
'util-linux-selinux' 'xz' 'audit' 'libselinux')
provides=('nss-myhostname' "systemd-tools=$pkgver" "udev=$pkgver"
"${pkgname/-selinux}=${pkgver}-${pkgrel}")