summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2023-11-12 15:18:18 +0100
committerNicolas Iooss2023-11-12 15:18:18 +0100
commit39fed67da9a0c68b13f37109d256af05f92ea728 (patch)
treeeff731af119ed5dda149df6002c009ead8466b4f /PKGBUILD
parentbf9f16aa653103a391ad6776e3a6ca17db2366db (diff)
downloadaur-39fed67da9a0c68b13f37109d256af05f92ea728.tar.gz
systemd-selinux 254.6-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68e01f93b2d5..66bc00bef002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@ pkgname=('systemd-selinux'
'systemd-resolvconf-selinux'
'systemd-sysvcompat-selinux'
'systemd-ukify-selinux')
-_tag='42f5ba1e56ddb81c244e0d85f13109acdb14cbee' # git rev-parse v${_tag_name}
-_tag_name=254.5
+_tag='5afac6471beec5401efb51f88990eaf92f3f9507' # git rev-parse v${_tag_name}
+_tag_name=254.6
pkgver="${_tag_name/-/}"
pkgrel=1
arch=('x86_64' 'aarch64')
@@ -232,7 +232,8 @@ package_systemd-selinux() {
mv "$pkgdir"/usr/share/man/man3 systemd-libs/man3
# ukify shipped in separate package
- install -d -m0755 systemd-ukify/{systemd,man1}
+ install -d -m0755 systemd-ukify/{install.d,systemd,man1}
+ mv "$pkgdir"/usr/lib/kernel/install.d/{60-ukify,90-uki-copy}.install systemd-ukify/install.d/
mv "$pkgdir"/usr/lib/systemd/ukify systemd-ukify/systemd/
mv "$pkgdir"/usr/share/man/man1/ukify.1 systemd-ukify/man1/
@@ -335,7 +336,8 @@ package_systemd-ukify-selinux() {
optdepends=('python-pillow: Show the size of splash image'
'sbsigntools: Sign the embedded kernel')
- install -d -m0755 "$pkgdir"/usr/{lib,share/man}
+ install -d -m0755 "$pkgdir"/usr/{lib/kernel,share/man}
+ mv systemd-ukify/install.d "$pkgdir"/usr/lib/kernel/install.d
mv systemd-ukify/systemd "$pkgdir"/usr/lib/systemd
mv systemd-ukify/man1 "$pkgdir"/usr/share/man/man1
}