summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2015-06-25 20:12:07 +0800
committerNicolas Iooss2015-06-27 11:45:01 +0800
commit3a48bb65a7b98e20cc0fe82f024fd2f6ff24ce6d (patch)
tree84a220c8322cfd0fd63e2aca1c18b36ee4c35d3a /PKGBUILD
parent6324616d71d07cb709b94d881282bb122fc44070 (diff)
downloadaur-3a48bb65a7b98e20cc0fe82f024fd2f6ff24ce6d.tar.gz
systemd-selinux 221-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD85
1 files changed, 35 insertions, 50 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c57b5a0e778..8a85826b6ab2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,59 +6,44 @@
pkgbase=systemd-selinux
pkgname=('systemd-selinux' 'libsystemd-selinux' 'systemd-sysvcompat-selinux')
-pkgver=219
-pkgrel=6
+pkgver=221
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
groups=('selinux')
-makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gobject-introspection' 'gperf'
- 'gtk-doc' 'intltool' 'iptables' 'kmod' 'libcap' 'libidn' 'libgcrypt'
- 'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers' 'lz4' 'pam-selinux'
- 'python' 'python-lxml' 'quota-tools' 'shadow-selinux' 'xz' 'audit' 'libselinux')
+makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'lz4' 'xz' 'pam-selinux'
+ 'intltool' 'iptables' 'kmod' 'libcap' 'libidn' 'libgcrypt'
+ 'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers'
+ 'python' 'python-lxml' 'quota-tools' 'shadow-selinux' 'gnu-efi-libs' 'git'
+ 'libselinux')
options=('strip' 'debug')
-source=("http://www.freedesktop.org/software/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz"
+# Retrieve the splash-arch.bmp image from systemd package sources, as this
+# file is too big to fit in the AUR.
+source=("git://github.com/systemd/systemd.git#tag=v$pkgver"
'initcpio-hook-udev'
'initcpio-install-systemd'
'initcpio-install-udev'
- '0001-tmpfiles-avoid-creating-duplicate-acl-entries.patch'
- '0001-nspawn-when-connected-to-pipes-for-stdin-stdout-pass.patch'
- '0001-core-shared-in-deserializing-match-same-files-reache.patch'
- '0001-tmpfiles-Fix-handling-of-duplicate-lines.patch'
- '0001-core-do-not-spawn-jobs-or-touch-other-units-during-c.patch'
- '0001-use-x-machine-unix-prefix-for-the-container-bus-on-dbus1.patch'
- '0001-unit-use-weaker-dependencies-between-mount-and-devic.patch'
- '0001-core-rework-device-state-logic.patch'
- '0001-core-don-t-change-removed-devices-to-state-tentative.patch')
-md5sums=('e0d6c9a4b4f69f66932d2230298c9a34'
+ 'arch.conf'
+ 'loader.conf'
+ 'splash-arch.bmp::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/splash-arch.bmp?h=packages/systemd&id=e43ddb71a5b1ab56e898347a63e54c5d5d07728a')
+md5sums=('SKIP'
'90ea67a7bb237502094914622a39e281'
- '58af51bd4c0464f195b3433b4e17cf6c'
+ '8516a7bd65157d0115c113118c10c3f3'
'bde43090d4ac0ef048e3eaee8202a407'
- '7cdefc73bf61934c353e4450e280e551'
- 'cb8550749cd52b5902ed6fdf0eb465ec'
- '9d46aebfc04cc849fd4295f449b239a2'
- 'c4c9c0f0a06314450563ed571962881e'
- '6b9d611dffd92c94641360c3ef2659c1'
- '3a0fc672b34ced18ca1364edf8644165'
- 'cd2719e8e93ad662c00bf9f195fdce66'
- '12e01f00c91e54680098a799517698f2'
- 'd0aa4e5ec598063eab2e79fb95bceece')
+ '20ead378f5d6df4b2a3e670301510a7d'
+ 'ddaef54f68f6c86c6c07835fc668f62a'
+ '1e2f9a8b0fa32022bf0a8f39123e5f4e')
prepare() {
- cd "${pkgname/-selinux}-$pkgver"
-
- patch -Np1 <../0001-tmpfiles-avoid-creating-duplicate-acl-entries.patch
- patch -Np1 <../0001-nspawn-when-connected-to-pipes-for-stdin-stdout-pass.patch
- patch -Np1 <../0001-core-shared-in-deserializing-match-same-files-reache.patch
- patch -Np1 <../0001-tmpfiles-Fix-handling-of-duplicate-lines.patch
- patch -Np1 <../0001-core-do-not-spawn-jobs-or-touch-other-units-during-c.patch
- patch -Np1 <../0001-use-x-machine-unix-prefix-for-the-container-bus-on-dbus1.patch
- patch -Np1 <../0001-unit-use-weaker-dependencies-between-mount-and-devic.patch
- patch -Np1 <../0001-core-rework-device-state-logic.patch
- patch -Np1 <../0001-core-don-t-change-removed-devices-to-state-tentative.patch
+ cd "${pkgname/-selinux}"
+
+ # 'git cherry-pick -n' upstream fixes here
+
+ ./autogen.sh
}
build() {
- cd "${pkgname/-selinux}-$pkgver"
+ cd "${pkgname/-selinux}"
local timeservers=({0..3}.arch.pool.ntp.org)
@@ -67,10 +52,9 @@ build() {
--localstatedir=/var \
--sysconfdir=/etc \
--enable-audit \
- --enable-introspection \
- --enable-gtk-doc \
--enable-lz4 \
--enable-compat-libs \
+ --enable-gnuefi \
--enable-selinux \
--disable-ima \
--disable-kdbus \
@@ -82,12 +66,12 @@ build() {
}
check() {
- make -C "${pkgname/-selinux}-$pkgver" check || :
+ make -C "${pkgname/-selinux}" check || :
}
package_systemd-selinux() {
pkgdesc="system and service manager with SELinux support"
- license=('GPL2' 'LGPL2.1' 'MIT')
+ license=('GPL2' 'LGPL2.1')
depends=('acl' 'bash' 'dbus' 'glib2' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
'libgcrypt' 'libsystemd-selinux' 'libidn' 'lz4' 'pam-selinux' 'libseccomp'
'util-linux-selinux' 'xz' 'audit' 'libselinux')
@@ -124,7 +108,7 @@ package_systemd-selinux() {
etc/udev/udev.conf)
install="systemd.install"
- make -C "${pkgname/-selinux}-$pkgver" DESTDIR="$pkgdir" install
+ make -C "${pkgname/-selinux}" DESTDIR="$pkgdir" install
# don't write units to /etc by default. some of these will be re-enabled on
# post_install.
@@ -134,7 +118,7 @@ package_systemd-selinux() {
rm -r "$pkgdir/usr/lib/rpm"
# add back tmpfiles.d/legacy.conf
- install -m644 "systemd-$pkgver/tmpfiles.d/legacy.conf" "$pkgdir/usr/lib/tmpfiles.d"
+ install -m644 "${pkgname/-selinux}/tmpfiles.d/legacy.conf" "$pkgdir/usr/lib/tmpfiles.d"
# Replace dialout/tape/cdrom group in rules with uucp/storage/optical group
sed -i 's#GROUP="dialout"#GROUP="uucp"#g;
@@ -172,18 +156,19 @@ package_systemd-selinux() {
rm -rf "$srcdir/_libsystemd"
install -dm755 "$srcdir"/_libsystemd/usr/lib
cd "$srcdir"/_libsystemd
- mv "$pkgdir"/usr/lib/lib{systemd,{g,}udev}*.so* usr/lib
+ mv "$pkgdir"/usr/lib/lib{systemd,udev}*.so* usr/lib
- # include MIT license, since it's technically custom
- install -Dm644 "$srcdir/${pkgname/-selinux}-$pkgver/LICENSE.MIT" \
- "$pkgdir/usr/share/licenses/${pkgname}/LICENSE.MIT"
+ # add example bootctl configuration
+ install -Dm644 "$srcdir/arch.conf" "$pkgdir"/usr/share/systemd/bootctl/arch.conf
+ install -Dm644 "$srcdir/loader.conf" "$pkgdir"/usr/share/systemd/bootctl/loader.conf
+ install -Dm644 "$srcdir/splash-arch.bmp" "$pkgdir"/usr/share/systemd/bootctl/splash-arch.bmp
}
package_libsystemd-selinux() {
pkgdesc="systemd client libraries with SELinux support"
depends=('glib2' 'glibc' 'libgcrypt' 'lz4' 'xz')
license=('GPL2')
- provides=('libgudev-1.0.so' 'libsystemd.so' 'libsystemd-daemon.so' 'libsystemd-id128.so'
+ provides=('libsystemd.so' 'libsystemd-daemon.so' 'libsystemd-id128.so'
'libsystemd-journal.so' 'libsystemd-login.so' 'libudev.so'
"${pkgname/-selinux}=${pkgver}-${pkgrel}")
conflicts=("${pkgname/-selinux}")