summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2015-02-22 09:17:22 +0800
committerNicolas Iooss2015-06-27 11:44:59 +0800
commit8090a768165b77f07e81eacd0c64d90614127bfc (patch)
tree4e724a2b7200c1253bfb31e573dc378c8701fc07 /PKGBUILD
parentbb5a76b47a420e5d9c40e5509b81fb667a7cad39 (diff)
downloadaur-8090a768165b77f07e81eacd0c64d90614127bfc.tar.gz
systemd-selinux 218-2 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 48 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 174b21173c46..36f63b969beb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=systemd-selinux
pkgname=('systemd-selinux' 'libsystemd-selinux' 'systemd-sysvcompat-selinux')
pkgver=218
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
groups=('selinux')
@@ -19,11 +19,56 @@ options=('strip' 'debug')
source=("http://www.freedesktop.org/software/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz"
'initcpio-hook-udev'
'initcpio-install-systemd'
- 'initcpio-install-udev')
+ 'initcpio-install-udev'
+ 0001-journal-fix-dangling-else-ambiguity.patch
+ 0002-nspawn-properly-validate-machine-names.patch
+ 0003-systemctl-fix-argument-handling-when-invoked-as-shut.patch
+ 0004-systemctl-properly-iterate-through-service-array-whe.patch
+ 0005-nss-myhostname-always-will-in-canonical-hostname-fie.patch
+ 0010-log-fix-log_full_errno-with-custom-facilities.patch
+ 0014-timesyncd-consider-too-long-packets-as-invalid.patch
+ 0016-logind-fix-sd_eviocrevoke-ioctl-call.patch
+ 0019-sd-bus-fix-handling-of-double-parameters-in-sd_bus_m.patch
+ 0021-units-fix-all-TTY-paths-for-container-gettys.patch
+ 0024-sd-dhcp-chop-of-trailing-dot-of-DHCP-supplied-host-a.patch
+ 0025-logind-handle-closing-sessions-over-daemon-restarts.patch
+ 0026-core-make-setting-the-shutdown-watchdog-configuratio.patch
+ 0027-sd-rtnl-don-t-fail-event-handler-when-callback-fails.patch
+ 0029-config_parse_set_status-put-signals-in-the-correct-s.patch
+ 0030-network-address-test-network-avoid-undefined-behavio.patch
+ 0033-core-disarm-shutdown-watchdog-if-we-fail-to-set-time.patch
+ 0034-exit-on-idle-only-exit-if-actually-idle.patch)
md5sums=('4e2c511b0a7932d7fc9d79822273aac6'
'90ea67a7bb237502094914622a39e281'
'c9db3010602913559295de3481019681'
- 'bde43090d4ac0ef048e3eaee8202a407')
+ 'bde43090d4ac0ef048e3eaee8202a407'
+ '22920ff32e345a26a9c05662ec274314'
+ '6960b43aaec4f899fdf0fe87d0457901'
+ '715cefd0e803d8b441811688fd4da1c3'
+ '3bb57f2812572ee999928ba33b489afe'
+ '5d42fda1f10c02861ee454277b516716'
+ 'a079c6e5c8d0184adf47794aaf338ac4'
+ 'c9b4e7bff3d1c073852c3d1b3bb8002e'
+ 'ae4d820582570ceb7b7c80b6810596f1'
+ '5b212435622f69c2a24b01ef7380bc94'
+ '0523c9ae27abdd30b847625b1c9c7a03'
+ 'c0d236b41dd4afad3f91dee72bb296a8'
+ '25e191463fb877fd5dabecb95f15ee8f'
+ '5911ef7d3ab5c5a06076fdea221ea27e'
+ 'ab7baf675e224cf19b9194fc1e4ea5ff'
+ '1d6cb563b3864fd8d724982bc2007f16'
+ '529c4fba7e0a709fda9e108e658e76c3'
+ '9d0d909507294afb879965e74fef79c8'
+ 'c0b68cefe7f00ea5ec856c64f799cca4')
+
+prepare() {
+ cd "${pkgname/-selinux}-$pkgver"
+
+ for p in "${source[@]}"; do
+ [[ $p = *.patch ]] || continue
+ patch -Np1 <"../$p"
+ done
+}
build() {
cd "${pkgname/-selinux}-$pkgver"