summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2016-10-04 22:57:26 +0200
committerNicolas Iooss2016-10-04 22:57:26 +0200
commitfe26e18109aa4ac6ae38dcd367bb451910218deb (patch)
treeca689c106995d674cc55a63cd79a3c4ce584c573 /PKGBUILD
parentd802d83e709e71abbbf23b1a817bbbd2d2a7ee82 (diff)
downloadaur-fe26e18109aa4ac6ae38dcd367bb451910218deb.tar.gz
systemd-selinux 231-3 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2277020c2f5d..05736ea99322 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=systemd-selinux
pkgname=('systemd-selinux' 'libsystemd-selinux' 'systemd-sysvcompat-selinux')
pkgver=231
-pkgrel=1
+pkgrel=3
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
groups=('selinux')
@@ -29,7 +29,7 @@ source=("git://github.com/systemd/systemd.git#tag=v$pkgver"
'udev-hwdb.hook')
md5sums=('SKIP'
'90ea67a7bb237502094914622a39e281'
- 'bee7fd6ccda39582259708e3f262ea6d'
+ '55ea7d81c02d090b65c42a88f1a5a21a'
'1b3aa3a0551b08af9305d33f85b5c2fc'
'20ead378f5d6df4b2a3e670301510a7d'
'ddaef54f68f6c86c6c07835fc668f62a'
@@ -37,6 +37,10 @@ md5sums=('SKIP'
'a475a5ed8f03fb0f6b58b4684998d05c')
_backports=(
+ '531ac2b2349da02acc9c382849758e07eb92b020' # If the notification message length is 0, ignore the message
+ '8523bf7dd514a3a2c6114b7b8fb8f308b4f09fc4' # pid1: process zero-length notification messages again
+ '9987750e7a4c62e0eb8473603150596ba7c3a015' # pid1: don't return any error in manager_dispatch_notify_fd()
+ 'bd64d82c1c0e3fe2a5f9b3dd9132d62834f50b2d' # Revert "pid1: reconnect to the console before being re-executed"
)
prepare() {
@@ -167,6 +171,7 @@ package_libsystemd-selinux() {
"${pkgname/-selinux}=${pkgver}-${pkgrel}")
conflicts=("${pkgname/-selinux}")
+ # TODO(dreisner): for v232, this should be install-rootlibLTLIBRARIES.
make -C "${pkgbase/-selinux}" DESTDIR="$pkgdir" install-libLTLIBRARIES
}