summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZesko2022-08-28 20:06:32 +0200
committerZesko2022-08-28 20:06:32 +0200
commiteaef8cf94f3c0b9660699f143fc1b64b9edfe5f9 (patch)
treefc7b4d48eba375d27e29479fa02437d2cb82a685 /PKGBUILD
downloadaur-eaef8cf94f3c0b9660699f143fc1b64b9edfe5f9.tar.gz
Added PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2c6b30950be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Zesko
+pkgname=systemd-timer-notify-git
+pkgver=r5.fed1ef7
+pkgrel=1
+pkgdesc="The notification displays on Desktop when systemd-service is started and processed, the notification will be closed automatically when systemd-service's process is done."
+arch=('any')
+url="https://gitlab.com/Zesko/systemd-timer-notify.git"
+license=('GPL3')
+depends=('python' 'dunst' 'systemd')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+backup=("etc/${pkgname%-git}.conf")
+source=('git+https://gitlab.com/Zesko/systemd-timer-notify.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ cp -vr usr etc "$pkgdir"
+}