summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonne Haß2021-04-12 09:34:46 +0200
committerJonne Haß2021-04-12 09:34:46 +0200
commitc2235093cd366b2f76fc9dfb7fdd8c33766a8405 (patch)
tree14a69a39752747ca0b70b03d3daefddba32adb78 /PKGBUILD
downloadaur-c2235093cd366b2f76fc9dfb7fdd8c33766a8405.tar.gz
systemd_http_health_check: add
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ade095b3e37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jonne Haß <me@jhass.eu>
+pkgname=systemd_http_health_check
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A companion daemon to notify systemd about the health of a HTTP server"
+arch=('x86_64')
+url="http://github.com/jhass/systemd_http_health_check"
+license=('BSD')
+depends=('systemd-libs')
+makedepends=('crystal')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jhass/systemd_http_health_check/archive/refs/tags/v$pkgver.tar.gz")
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ shards install
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ shards build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"
+}
+sha256sums=('e999136e262c7f7896940af5718ad14f114bcf204c3bc1df1ce39ac4d27cdf90')