summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2018-12-09 22:09:53 -0500
committerAndrew Sun2018-12-09 22:09:53 -0500
commitcdf14a6466c199fd33f96f9d231c163506f70d8a (patch)
treea56848fcd281ffa1317dea5e92349274e117f086 /PKGBUILD
parentb0873d343cc30954f984853cb95c83cc3d7340d8 (diff)
downloadaur-systempreferences.tar.gz
systempreferences: update to 1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59fc7240eec4..b759fcf24d81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
-# Maintainer: Thomas Ascher <thomas.ascher@gmx.at>
+# Maintainer: Andrew Sun <adsun701@gmail.com>
# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+
pkgname=systempreferences
_pkgname=SystemPreferences
+pkgver=1.2.0
pkgrel=1
-pkgver=1.1.0
pkgdesc="An application which allows to manage the settings of many aspects of the gnustep environment and its applications."
arch=('i686' 'x86_64')
-url="http://www.gnustep.org/experience/$pkgname.html"
-license=('GPL')
-install=$pkgname.install
+url="http://www.gnustep.org/experience/systempreferences.html"
+license=('GPL2')
+install="${pkgname}.install"
depends=('gnustep-base'
- 'gnustep-gui')
+ 'gnustep-gui'
+ 'gnustep-back')
makedepends=('gcc-objc'
'gnustep-make')
-source=("ftp://ftp.gnustep.org/pub/gnustep/usr-apps/$_pkgname-$pkgver.tar.gz"
- "$pkgname.install")
-sha256sums=('c7dffa3b33949e26c319aa2adbda8e9168e51d2f1a0790d5ec0d609a915ec8e0'
- 'f703f8de14eb277dc72cc837086fbd55f5d772049a44200686c8ae76348f6614')
+source=("ftp://ftp.gnustep.org/pub/gnustep/usr-apps/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('690cfd28552c5883fe06a89283f44574f41d937627b41c8435743f07e360e7b9')
build() {
- cd "$_pkgname-$pkgver"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
make
}
package() {
- cd "$_pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
- install -D -m644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" \
- "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${pkgdir}/usr/lib/GNUstep/Applications/${_pkgname}.app/Resources/${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
}