summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Angelopoulos2018-06-03 16:35:39 +0200
committerGeorge Angelopoulos2018-06-03 16:35:39 +0200
commita2db70026d5b044f8110c7b39591cca716ba536a (patch)
tree98d8b7f2939e2bd8ad7aa9d53302349e596ebbc3 /PKGBUILD
parentdda4d2e8984e62619e278b196fcd150efb8d485f (diff)
downloadaur-a2db70026d5b044f8110c7b39591cca716ba536a.tar.gz
backport gcc8 fix to 3.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1757e2c2a47b..77ca142a9fc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor:dront78 <dront78@gmail.com>
pkgname=systemtap
pkgver=3.2
-pkgrel=2
+pkgrel=3
pkgdesc="provides infrastructure to simplify the gathering of information about the running system."
url="http://sourceware.org/systemtap/"
arch=('x86_64' 'i686')
@@ -12,16 +12,19 @@ makedepends=('python2-setuptools' 'xmlto')
optdepends=('sqlite3: for storing results in a database')
source=("${pkgname}-${pkgver}.tar.gz::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz"
"${pkgname}-${pkgver}.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz.asc"
- 'stp_remove_install_hooks.patch')
+ 'stp_remove_install_hooks.patch'
+ 'fixes-for-gcc-8.patch')
sha512sums=('6036ed1b5189fd3fcfdeeaa526a3539ac632d0b687a063b5e3424e8f613bfc2c8d079742b0262b547128e97e30e4beb61898b23761657aee519e61346ac92e94'
'SKIP'
- '1d2758e9f875e06d08d37679587454fb43e025aa83ceeb405b1bc8d3277476502f2d67cf9e8383cc4c63ae545d7d0e9ebaab814f880b2f53bba47bef4afcd537')
+ '1d2758e9f875e06d08d37679587454fb43e025aa83ceeb405b1bc8d3277476502f2d67cf9e8383cc4c63ae545d7d0e9ebaab814f880b2f53bba47bef4afcd537'
+ '970d83ace43909e5a1bfc4112d78dd913af6d59e4b8dc8c4461370b022092b0cdb6830427b52bcf5b7409ff6d7c79dab778e53398ba65de71bd4a270c66a2d3a')
install='systemtap.install'
validpgpkeys=('5D38116FA4D3A7CC77E378D37E83610126DCC2E8')
prepare() {
cd "${pkgname}-${pkgver}"
patch -Np1 -i "${srcdir}/stp_remove_install_hooks.patch"
+ patch -Np1 -i "${srcdir}/fixes-for-gcc-8.patch"
autoreconf -i
}
build() {