summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSébastien Luttringer2018-11-18 22:47:31 +0100
committerSébastien Luttringer2018-11-18 22:47:31 +0100
commite536a0f0647a44ff30b3deab3c880a91bb7e2ca6 (patch)
tree3f3dd2a8ae24039c6b9ed9897940242909aad645 /PKGBUILD
downloadaur-e536a0f0647a44ff30b3deab3c880a91bb7e2ca6.tar.gz
Initial Commit
Moved from community
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99379a0f10e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
+
+pkgname=sysvbanner
+pkgver=1.0.16
+pkgrel=1
+pkgdesc='System-V banner clone'
+arch=('x86_64')
+url='https://tracker.debian.org/pkg/sysvbanner'
+depends=('glibc')
+conflicts=('bsd-games')
+license=('custom')
+source=("http://ftp.debian.org/debian/pool/main/s/sysvbanner/${pkgname}_${pkgver}.tar.gz"
+ '01-man.patch')
+sha512sums=('55987c3dbaf898e80476a08e755194480760a59b78eb879c3db11994b0ed6e11894ffc762a932ad0d95decf9dcb46dc9d905210788f1ce1dad14e00895654409'
+ '14255d0a35be028728095921e3153861cd296612ab790e213413cc7f4da7690f60451ea76952f7877c17538c13cb44da71f353278c06f3700845656c9d98d609')
+
+prepare() {
+ cd $pkgname-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
+
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -D -m444 "debian/copyright" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: