summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Bus2017-10-08 00:05:37 +0700
committerAlexander Bus2017-10-08 00:05:37 +0700
commit1bbd44226698f5cfcd46ba64f579799074c43e8a (patch)
treedf8425c6e4bffd41f40e5d0d783f630163512205 /PKGBUILD
downloadaur-1bbd44226698f5cfcd46ba64f579799074c43e8a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2de5c48206e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+
+pkgname=szsol-git
+pkgver=r34.14af5a5
+pkgrel=1
+pkgdesc="ncurses clone of Shenzhen Solitaire"
+arch=('any')
+url="https://github.com/usrshare/szsol"
+license=('MIT')
+makedepends=('git' 'ncurses5-compat-libs')
+source=('git+https://github.com/usrshare/szsol')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/szsol"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/szsol"
+ make
+}
+
+package() {
+ # cd "$srcdir/szsol"
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$srcdir/szsol/szsol" "$pkgdir/usr/bin"
+ install -Dm644 $srcdir/szsol/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}