summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpiotr2018-11-25 23:03:42 +0100
committerpiotr2018-11-25 23:03:42 +0100
commit66516d196ee8ea0107a7b20478f92666da34a95a (patch)
tree22b4982cc0b7b69297cac47aabc10ec14b207f9b /PKGBUILD
downloadaur-66516d196ee8ea0107a7b20478f92666da34a95a.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD116
1 files changed, 116 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2f97c14807e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,116 @@
+# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
+pkgname=('t2ec')
+pkgver=0.1
+pkgrel=9
+pkgdesc="A package of scripts to display system icons and controls in Tint2 panel"
+arch=('x86_64')
+url="https://github.com/nwg-piotr/tint2-executors"
+license=('GPL3')
+depends=('python' 'acpi' 'xorg-xbacklight' 'alsa-utils' 'wireless_tools')
+optdepends=('light-git: for machines not handling xbacklight'
+ 'rof-git: for running mouse events commands as single instances'
+ 'zenity: for volume and brightness slider box')
+
+source=("https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec-lib/battery-icon.sh"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec-lib/bbswitch-status-temp.sh"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec-lib/brightness-icon-light.sh"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec-lib/brightness-icon.sh"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec-lib/desktop.py"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec-lib/volume-icon.sh"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec-lib/wifi-name.sh"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec-lib/arch-update.py"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec-lib/zenity-box.sh"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/arch-package/t2ec-lib/help.sh"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bat-empty-charging.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bat-empty.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bat-full-charging.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bat-full.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bat-half-charging.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bat-half.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bat-quarter-charging.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bat-quarter.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bat-threefourth-charging.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bat-threefourth.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bri-full.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bri-high.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bri-low.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/bri-medium.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/desktop.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/network.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/no-bumblebee.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/nvidia-off.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/nvidia.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/vol-full.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/vol-low.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/vol-lowest.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/vol-medium.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/vol-muted.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/arch-icon.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/arch-icon-notify.svg"
+ "https://github.com/nwg-piotr/tint2-executors/raw/master/images/arch-update48.svg")
+
+md5sums=('8a02b12a94a553f860cb91ac14a55324'
+ 'b86f03023ea9a927c90a50e12c51d05b'
+ '921064d0eb82b775080872a5507e820d'
+ '1dae806f7c7b0eb34cda8468b4631474'
+ '5019cebbf405090d789c1ef5469478b4'
+ '5193ce4ee5ab775c709410df111717b0'
+ '63a955c04f03451a13fd4a5f3ea1bbf3'
+ '4d5efb2581959b68db65a0964e1c26b9'
+ 'c6ca68e09a73a7a6a34afa6943d70004'
+ 'f9a82c34f8f4228c5dc194b0fb7b37a0'
+ '316a161692a5699761e73e624adb723b'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+package() {
+ install -D -m 755 t2ec \
+ "$pkgdir"/usr/bin/t2ec
+ install -D -m 755 battery-icon.sh \
+ "$pkgdir"/usr/lib/$pkgname/battery-icon.sh
+ install -D -m 755 bbswitch-status-temp.sh \
+ "$pkgdir"/usr/lib/$pkgname/bbswitch-status-temp.sh
+ install -D -m 755 brightness-icon-light.sh \
+ "$pkgdir"/usr/lib/$pkgname/brightness-icon-light.sh
+ install -D -m 755 brightness-icon.sh \
+ "$pkgdir"/usr/lib/$pkgname/brightness-icon.sh
+ install -D -m 755 desktop.py \
+ "$pkgdir"/usr/lib/$pkgname/desktop.py
+ install -D -m 755 volume-icon.sh \
+ "$pkgdir"/usr/lib/$pkgname/volume-icon.sh
+ install -D -m 755 wifi-name.sh \
+ "$pkgdir"/usr/lib/$pkgname/wifi-name.sh
+ install -D -m 755 arch-update.py \
+ "$pkgdir"/usr/lib/$pkgname/arch-update.py
+ install -D -m 755 zenity-box.sh \
+ "$pkgdir"/usr/lib/$pkgname/zenity-box.sh
+ install -D -m 755 help.sh \
+ "$pkgdir"/usr/lib/$pkgname/help.sh
+ install -D -t "$pkgdir/usr/share/$pkgname" *.svg
+}