summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Werling2017-06-20 23:41:09 +0200
committerLukas Werling2017-06-20 23:41:09 +0200
commitdaac6dbc32e2bce3d9653bd5dfee14b2aee4f302 (patch)
treed009f082daa210b1b41d71695056b7d7409c4b2b /PKGBUILD
parent6bc2919e9934f49f5caf119673058587fe5f6d97 (diff)
downloadaur-daac6dbc32e2bce3d9653bd5dfee14b2aee4f302.tar.gz
Add check() which runs the tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ea02934e3f1..e0bd686fb533 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ url="http://tkatchev.bitbucket.org/tab/"
license=('custom:boost')
depends=('gcc-libs')
makedepends=()
+checkdepends=('python2')
source=("https://bitbucket.org/tkatchev/tab/get/${pkgver}.tar.bz2")
sha256sums=('19edd1183ee0e3bb9d79e022141567779ef42d9ebddbfd09317aaf5bc700be8d')
@@ -18,6 +19,11 @@ build() {
make
}
+check() {
+ cd "$_dirname"
+ make test
+}
+
package() {
cd "$_dirname"
install -Dm755 tab -t "$pkgdir/usr/bin/"