summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2020-04-16 18:57:51 +0200
committerMartchus2020-04-16 18:57:51 +0200
commit935bc3a7b4aeb6ae022b7d0b93ae1e13931c9c21 (patch)
treef530780c1b8d0b3c13abd6d0098c54c1761227e8 /PKGBUILD
downloadaur-935bc3a7b4aeb6ae022b7d0b93ae1e13931c9c21.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29d408cc4df0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+# A minimal version of tageditor which has only the CLI enabled and no JSON export
+# by default.
+
+# whether the experimental JSON export is enabled: ON or OFF
+_json_export=${TAGEDITOR_JSON_EXPORT:-OFF}
+
+_reponame=tageditor
+pkgname=tageditor-cli
+pkgver=3.3.6
+pkgrel=1
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+pkgdesc='A tag editor with command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska (GUI disabled)'
+license=('GPL')
+depends=('c++utilities' 'tagparser')
+makedepends=('cmake')
+conflicts=("${pkgname%-cli}")
+provides=("${pkgname%-cli}")
+[[ $_json_export == ON ]] && makedepends+=('reflective-rapidjson')
+checkdepends=('cppunit')
+url="https://github.com/Martchus/${_reponame}"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
+sha256sums=('23cd6e03732757ef4e0d4a5fc6f2257a37b2eaa127da87a8be6a9bff5ec379b6')
+
+build() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ cmake \
+ -DCMAKE_BUILD_TYPE:STRING='Release' \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DWIDGETS_GUI=OFF \
+ -DQUICK_GUI=OFF \
+ -DENABLE_JSON_EXPORT="${_json_export}" \
+ -DREFLECTION_GENERATOR_EXECUTABLE:FILEPATH='/usr/bin/reflective_rapidjson_generator' \
+ .
+ make
+}
+
+check() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ if [[ $TEST_FILE_PATH ]]; then
+ make check
+ else
+ msg2 'Skipping execution of testsuite because the environment variable TEST_FILE_PATH is not set.'
+ fi
+}
+
+package() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ make DESTDIR="${pkgdir}" install
+}