summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorskydrome2015-06-18 09:19:32 -0400
committerskydrome2015-06-18 09:19:32 -0400
commit72b4dccc810220784119d6304c10138f278a6409 (patch)
treed139dc7c2f8983e4adeea17204393afb6bacd210 /PKGBUILD
downloadaur-72b4dccc810220784119d6304c10138f278a6409.tar.gz
v.1.10.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50d9edd5b228
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer : Skydrome <skydrome@i2pmail.org>
+# Contributor: DaNiMoTh <jjdanimoth@gmail.com>
+# Contributor (Arch): Peter Simons <simons@cryp.to>
+# Contributor (Arch): Nicolas Pouillard <nicolas.pouillard@gmail.com>
+
+pkgname=tahoe-lafs
+pkgver=1.10.1
+pkgrel=1
+pkgdesc="Secure, decentralized, and fault-tolerant filesystem."
+url='https://tahoe-lafs.org/trac/tahoe-lafs'
+license=('GPL')
+arch=('any')
+conflicts=('tahoe-lafs')
+provides=('tahoe-lafs')
+BUILDENV+=(!check)
+
+depends=('openssl>=1.0.2'
+ 'python2-twisted>=13.0.0'
+ 'python2-mock>=1.0.1'
+ 'python2-pyopenssl>=0.14'
+ 'python2-pyasn1>=0.1.4'
+ 'python2-pyasn1-modules>=0.0.5'
+ 'python2-zope-interface>=4.0.5'
+ 'python2-characteristic>=14.3.0'
+ 'python2-service-identity>=14.0.0'
+ 'python2-cryptography'
+ 'pyutil>=1.9.4'
+ 'python2-simplejson>=3.1.3'
+ 'nevow>=0.11.1'
+ 'zbase32>=1.1.5'
+ 'zfec>=1.4.24'
+ 'pycryptopp>=0.6.0'
+ 'python2-cffi'
+ 'python2-enum34'
+ 'python2-pycparser'
+ 'python2-six'
+ 'libffi'
+ 'python2-foolscap>=0.8.0'
+ 'net-tools' # provides /sbin/ifconfig
+ 'python2-setuptools')
+
+optdepends=('python2-numpy: reliability test')
+
+source=("https://tahoe-lafs.org/source/tahoe-lafs/releases/allmydata-tahoe-$pkgver.tar.bz2")
+sha256sums=('5bde7bd28fdd23e7c312381e2818d75e90a80c40b18562f171510a7c716fd4c0')
+
+build(){
+ cd "${srcdir}/allmydata-tahoe-${pkgver}"
+ python2 setup.py build
+}
+
+check() {
+ cd "${srcdir}/allmydata-tahoe-${pkgver}"
+ msg "This may take a while"
+ python2 bin/tahoe debug trial $MAKEFLAGS
+}
+
+package(){
+ cd "${srcdir}/allmydata-tahoe-${pkgver}"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 COPYING.GPL "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}