summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfsckd2015-07-07 13:33:20 -0400
committerfsckd2015-07-07 13:33:20 -0400
commit6417f8d7fb8000ac2bc5c0bff599f2a3a5783dc9 (patch)
tree16e91e03f0cc10e6cfa684057eedd2f8c4c2a84f /PKGBUILD
downloadaur-taipan.tar.gz
new AUR4 repository
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..913ccbd1e41e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: fsckd <fsckdaemon at gmail dot com>
+
+pkgname=taipan
+pkgver=0.9
+pkgrel=1
+pkgdesc="Ncurses port of Art Canfil's classic Apple ][ game of China trade during the 1800's."
+url='http://www.ibiblio.org/pub/linux/games/textrpg/taipan-0.9.lsm'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('ncurses')
+source=("http://www.ibiblio.org/pub/linux/games/textrpg/taipan-0.9.tar.gz")
+sha256sums=('d51345e0e0aa599357fe7b8cb79f3f7109a78c15b852ba8a712f65701d7d5861')
+
+build()
+{
+ cd "${srcdir}/taipan-0.9"
+ make clean
+ make
+}
+
+package()
+{
+ local tardir="${srcdir}/taipan-0.9"
+ install -D -m0755 "${tardir}/taipan" "${pkgdir}/usr/bin/taipan"
+ install -D -m0644 "${tardir}/README" "${pkgdir}/usr/share/doc/${pkgname}/README"
+}
+
+# TODO patch author's current email