summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrei "Akari" Alexeyev2017-09-27 19:58:05 +0300
committerAndrei "Akari" Alexeyev2017-09-27 19:58:05 +0300
commit4e5a977deff2dd5b864d69c8da70c369afc6a525 (patch)
tree88ea74b5ed61cb9cdb2e3f2d402208bdddeb4df3 /PKGBUILD
parentd01a429b7ebc188c5a21ed7057ab993bd4fdb8ac (diff)
downloadaur-4e5a977deff2dd5b864d69c8da70c369afc6a525.tar.gz
update depends and pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 54889ef7bc0e..eb4c292e08c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Maintainer: Andrei Alexeyev <akari@alienslab.net>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Lukas Weber <laochailan@web.de>
pkgname=taisei-git
-pkgver=1.0a.r463.g67128fa
+pkgver=1.1.r19.ge0d76df
pkgrel=1
pkgdesc="Open source Touhou clone (development version)"
arch=('i686' 'x86_64')
url="http://taisei-project.org/"
license=('MIT')
-depends=('sdl2_mixer' 'sdl2_ttf' 'libgl' 'libpng')
+depends=('sdl2_mixer' 'sdl2_ttf' 'libzip' 'hicolor-icon-theme')
provides=('taisei')
conflicts=('taisei')
-makedepends=('git' 'cmake' 'mesa')
+makedepends=('git' 'cmake')
source=(taisei::"git+https://github.com/laochailan/taisei.git")
md5sums=('SKIP')
pkgver() {
cd taisei
- git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ git describe --long --tags --match "v[0-9]*[!a-z]" | sed 's/^v//;s/-/.r/;s/-/./'
}
build() {