summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxichen zhou2021-03-13 11:43:17 +0800
committerxichen zhou2021-03-13 11:43:17 +0800
commit3eb3138eeb4241a8a86c8df9c57be28ef786638f (patch)
tree5da2bbdcf8065a51ce126935b417df915c50942d /PKGBUILD
parentff4cfd84883e7793dc408eeeac3c66d6febdded7 (diff)
downloadaur-3eb3138eeb4241a8a86c8df9c57be28ef786638f.tar.gz
update pkgver()
Signed-off-by: xichen zhou <xzhou@xeechou.net>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c5e04cf9955..18d9b88a1fd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,30 @@
pkgname=taiwins-git
_pkgname=taiwins
-pkgver=0.2.0
-pkgrel=0
+pkgrel=1
+pkgver=v0.2.0.r0.g5f1f4ea
pkgdesc="Tiling and floating wayland window manager focused on speed and size"
url="https://taiwins.org"
license=('GPL2')
-source=("git+http://github.com/${_pkgname}/${_pkgname}.git")
+source=("git+https://github.com/${_pkgname}/${_pkgname}#tag=v0.2.0")
md5sums=('SKIP')
arch=('x86_64')
depends=( 'glibc' 'wayland>=1.17' 'libxkbcommon' 'libinput' 'pixman>=0.25.0'
'libdrm>=2.4.68' 'pam' 'systemd-libs' 'dbus' 'lua>=5.3.0' 'libxcursor'
'cairo' 'fontconfig' 'freetype2' 'librsvg' 'libgl' 'libegl' 'libgles'
- 'wlroots=0.11.0')
+ 'wlroots>=0.11.0')
makedepends=('meson' 'ninja' 'git' 'wayland-protocols>=1.18')
+pkgver() {
+ cd $srcdir/${_pkgname}
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd $srcdir/${_pkgname}
git fetch origin --tag
- git checkout tags/v0.2.0
git submodule update --init --recursive
if [ ! -d "subprojects/ctypes" ]; then
meson wrap promote subprojects/twclient/subprojects/ctypes