summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStorm Dragon2018-05-10 13:44:33 -0400
committerStorm Dragon2018-05-10 13:44:33 -0400
commit427b54be834a75d91526c0351714d1131bed6e21 (patch)
treefc3eeb1eb8ddcfcab4727871b85c80468e24042d /PKGBUILD
parent7bb5a9b70fad3cfdb9304b3ebc1586f284ccfcb6 (diff)
downloadaur-427b54be834a75d91526c0351714d1131bed6e21.tar.gz
Fixed empty version string.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d3101f85b76..d70b4c15a7c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,10 +27,10 @@ md5sums=("SKIP")
pkgver()
{
- cd "${_pkgname}"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
-}
-
+ cd "$_pkgname"
+ git shortlog | head -n 1 | tr -Cd "[:digit:]"
+}
+
package()
{
cd "$_pkgname"