summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRyan Farley2019-11-21 12:16:45 -0600
committerRyan Farley2019-11-21 12:16:45 -0600
commit85b9cf5d3153ab71439cf3a881c9873e36aef9f0 (patch)
treea08f03925fd2819eb7f74cfe43099a0276ce1e5f /PKGBUILD
downloadaur-85b9cf5d3153ab71439cf3a881c9873e36aef9f0.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b58b88afbe0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ryan Farley <ryan.farley@gmx.com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Scott Fial <scott at fial dot com>
+
+_pkgname=tamsyn-font
+pkgname=tamsyn-font-otb
+pkgver=1.11
+pkgrel=3
+pkgdesc="A monospaced bitmap font for the console and X11 (OTB Format)"
+arch=('any')
+url="http://www.fial.com/~scott/tamsyn-font"
+license=('custom')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils' 'fonttosfnt-git')
+source=("https://www.fial.com/~scott/$_pkgname/download/$_pkgname-$pkgver.tar.gz")
+md5sums=('6ec13672d2f0d6a829f2403cdeebd980')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ for f in *.pcf; do
+ fonttosfnt -o "${f/pcf/otb}" "$f"
+ done
+}
+
+package () {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ install -d "$pkgdir/usr/share/fonts/misc"
+ install -d "$pkgdir/usr/share/kbd/consolefonts"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+
+ install -m644 *.otb "$pkgdir/usr/share/fonts/misc/"
+ install -m644 *.psf.gz "$pkgdir/usr/share/kbd/consolefonts/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/"
+}