summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-11-23 19:57:39 -0700
committerMark Wagie2021-11-23 19:57:39 -0700
commit56fe583b2ffcae467ced3e14226d0de603832d72 (patch)
tree8b16ac1e860f63aa011789ba1ebc12596ff80c95 /PKGBUILD
parent902441966839861bd1424fbc86a0e3382c410ec3 (diff)
downloadaur-56fe583b2ffcae467ced3e14226d0de603832d72.tar.gz
add submodule
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9853c25db0ec..c06b92cd4a76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sonny Piers <sonny at fastmail dot net>
pkgname=tangram
pkgver=1.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Browser for your pinned tabs"
arch=('any')
url="https://apps.gnome.org/app/re.sonny.Tangram"
@@ -12,11 +12,20 @@ makedepends=('git' 'meson')
#checkdepends=('appstream-glib')
conflicts=('gigagram' "$pkgname-web")
replaces=("$pkgname-web")
-source=("$pkgname::git+https://github.com/sonnyp/Tangram.git#tag=v$pkgver")
-sha256sums=('SKIP')
+source=("git+https://github.com/sonnyp/Tangram.git#tag=v$pkgver"
+ 'git+https://github.com/sonnyp/troll.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/Tangram"
+ git submodule init
+ git config submodule.src/troll.url "$srcdir/troll"
+ git submodule update
+}
build() {
- arch-meson "$pkgname" build
+ arch-meson Tangram build
meson compile -C build
}