summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-10-25 10:56:31 -0600
committerMark Wagie2021-10-25 10:56:31 -0600
commit6093e91c0c7c341306cbe91888dd2110bd01b5bb (patch)
treedc74d3174478f1208bed8e8c2f42055ef03d0fee /PKGBUILD
parentbac11d45c280d2cff1ea33673cb00797a745130e (diff)
downloadaur-6093e91c0c7c341306cbe91888dd2110bd01b5bb.tar.gz
fix build with Meson 0.60.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9364a19673f7..8eb9174a9d1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Sonny Piers <sonny at fastmail dot net>
pkgname=tangram
-pkgver=1.3.1
-pkgrel=2
+pkgver=1.3.1+5+g8934dcd
+pkgrel=1
pkgdesc="Run web apps on your desktop."
arch=('any')
url="https://apps.gnome.org/app/re.sonny.Tangram"
@@ -12,11 +12,18 @@ conflicts=('gigagram' "$pkgname-web")
replaces=("$pkgname-web")
makedepends=('git' 'npm' 'meson')
#checkdepends=('appstream-glib')
-source=("${pkgname%-web}::git+https://github.com/sonnyp/Tangram.git#tag=v$pkgver"
+_commit=8934dcdb3ab43a04e2a210ec508c97c338a72ffe
+source=("${pkgname%-web}::git+https://github.com/sonnyp/Tangram.git#commit=$_commit"
+#source=("${pkgname%-web}::git+https://github.com/sonnyp/Tangram.git#tag=v$pkgver"
'git+https://github.com/sonnyp/troll.git')
sha256sums=('SKIP'
'SKIP')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
prepare() {
cd "$srcdir/$pkgname"
git submodule init