summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-01-17 17:56:42 -0700
committerMark Wagie2023-01-17 17:56:42 -0700
commit755a7c6165cee348547d61836996ca3142075280 (patch)
tree7a0e544fff64024b88e3506d5fc47c98dde82c7c /PKGBUILD
parent3713e86377e8d59f8c79ea0c29a66a18d13a8f71 (diff)
downloadaur-755a7c6165cee348547d61836996ca3142075280.tar.gz
2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffa543855687..02937f011a38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Sonny Piers <sonny at fastmail dot net>
pkgname=tangram
-pkgver=1.5.0
+pkgver=2.0
pkgrel=1
pkgdesc="Browser for your pinned tabs"
arch=('any')
url="https://apps.gnome.org/app/re.sonny.Tangram"
license=('GPL3')
-depends=('gjs' 'gtk3' 'libsoup3' 'webkit2gtk')
-makedepends=('git' 'meson')
+depends=('gjs' 'libadwaita' 'webkit2gtk')
+makedepends=('git' 'blueprint-compiler' 'meson')
checkdepends=('appstream-glib')
optdepends=('gst-plugins-bad: May be necessary for some websites')
-_commit=176249af8aedaf878fe7503d2838b10042967690 # tags/v1.5.0
+_commit=d2e9ecf74ba2e7348799f4e89cd80e18bb68a7fd # tags/v2.0
source=("git+https://github.com/sonnyp/Tangram.git#commit=${_commit}"
'git+https://github.com/sonnyp/troll.git')
sha256sums=('SKIP'
@@ -27,6 +27,9 @@ prepare() {
git submodule init
git config submodule.src/troll.url "$srcdir/troll"
git -c protocol.file.allow=always submodule update
+
+ # use system blueprint-compiler
+ sed -i 's|../blueprint-compiler/blueprint-compiler.py|/usr/bin/blueprint-compiler|g' src/meson.build
}
build() {