summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Yamnitsky2021-04-23 16:47:36 -0400
committerDavid Yamnitsky2021-04-23 16:47:36 -0400
commit83c99f13e1799b0585032b7e0e79e97ed6ed53ae (patch)
treeef7bf530f70fb004cb39ba131f4bf4391ed4230f /PKGBUILD
parentd1a4d8dc9a053ab1d478a1d5cbba84e773b6dbb9 (diff)
downloadaur-83c99f13e1799b0585032b7e0e79e97ed6ed53ae.tar.gz
v0.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 11 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08cd80f3c8c5..309864834084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,15 @@
-# Maintainer: Sonny Piers <sonny@fastmail.net>
+# Maintainer: nitsky
+arch=("x86_64")
+license=("MIT")
+pkgdesc="Tangram is an all-in-one machine learning toolkit designed for programmers."
pkgname=tangram
-pkgver=1.2.0
pkgrel=1
-pkgdesc="Run web apps on your desktop"
-arch=('any')
-url="https://github.com/sonnyp/Tangram"
-license=('GPL3')
-depends=('gjs' 'webkit2gtk' 'gtk3' 'libsoup' 'glib2')
-provides=('gigagram-git')
-conflicts=('gigagram-git')
-replaces=('gigagram-git')
-makedepends=('meson' 'ninja')
-source=("https://github.com/sonnyp/Tangram/archive/v$pkgver.tar.gz")
-sha256sums=('e3f7baae512ab355c817c9638e5b114306f635dd4cfc736f0fb0cfdb2012c7ee')
+pkgver=0.3.0
+provides=("tangram")
+sha256sums_x86_64=("030a0ad71ce5ce3d84a71a83ebddefe06469de055eec9e43ccdba901fcffd51f")
+source_x86_64=("https://github.com/tangramxyz/tangram/releases/download/v${pkgver}/tangram_cli_${pkgver}_x86_64-unknown-linux-gnu.tar.gz")
+url='https://www.tangram.xyz'
-build() {
- arch-meson Tangram-$pkgver build
- ninja -C build
-}
-
-package(){
- DESTDIR="$pkgdir" ninja -C build install
+package() {
+ install -D -m 755 tangram "$pkgdir/usr/bin/tangram"
}