summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOneOfOne2020-10-18 17:43:48 -0500
committerOneOfOne2020-10-18 17:43:48 -0500
commitd5d85c7dfb9fe39bb7c8f3d40aaac93014efa014 (patch)
tree7b4fbf446426619c8a8cadacac820b93a0dd7db3 /PKGBUILD
parent3f57a1dfddba10b1710fdff9343f9c2d5fd6e1d7 (diff)
downloadaur-d5d85c7dfb9fe39bb7c8f3d40aaac93014efa014.tar.gz
v1.10.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD85
1 files changed, 41 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a18f3f01b602..4197646931fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,52 @@
-# Maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
+# Maintainer: Ahmed W. <oneofone@gmail.com>
+# old maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
pkgname=tastyworks
-pkgver=1.0.16
-pkgrel=5
+pkgver='1.10.0'
+pkgrel='1'
pkgdesc="One of the fastest, most reliable, and most secure trading platforms in the world."
arch=('x86_64')
-url="https://tastyworks.com/technology.html"
-license=('Other')
-depends=('jre-openjdk')
-source=("https://download.tastyworks.com/desktop-1.x.x/$pkgver/$pkgname-$pkgver-1.x86_64.rpm"
- "tastyworks.png")
-sha256sums=('8a2c9bd54dd1736aa07e693839939988d94951537709cf1bd3e9263ce3368fd5'
- '5875675195bb9156c050976e00c98538a6662740f5359e677d26fe5e21560cea')
-
-prepare() {
- # Set correct permissions on executable files and libraries
- find "$srcdir" -name "*.jar" -type f -exec chmod 755 {} \;
- find "$srcdir" -name "*.so" -type f -exec chmod 755 {} \;
-
- # Set correct information for the application .desktop launcher
- sed -i 's|Name=tastyworks|Name=TastyWorks|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
- sed -i 's|Comment=tastyworks|Comment=Trading Platform|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
- sed -i 's|Exec=/opt/tastyworks/bin/tastyworks|Exec=/usr/bin/tastyworks|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
- sed -i 's|Icon=/opt/tastyworks/bin/tastyworks.png|Icon=tastyworks|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
- sed -i 's|Categories=tastyworks|Categories=Network|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
-
- # Add the correct startup window manager class
- # This *should* fix gnome from creating more than one dock entry for the program
- echo 'StartupWMClass=tasty.javafx.launcher.LauncherFxApp' >> "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
- sed -i '/^[[:space:]]*$/d' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
-
- # Remove additional bundled Java "runtime"
- sed -i 's|app.runtime=$APPDIR/runtime|app.runtime=/usr/lib/jvm/default-runtime|' "$srcdir/opt/$pkgname/app/tastyworks.cfg"
+url='https://tastyworks.com/'
+license=('custom:commercial')
+depends=('java-runtime')
+conflicts=('tastyworks-bin')
+
+source=(https://download.tastyworks.com/desktop-1.x.x/${pkgver}/tastyworks-${pkgver}-${pkgrel}_amd64.deb)
+sha256sums=('1fc05e1149aafc0820964323a36f85963737930855b9dcec00e5ef8abdcb6bd4')
+
+build() {
+ tar xf data.tar.xz
+
+ # Remove additional bundled Java "runtime"
+ rm -rf opt/tastyworks/lib/runtime
+ sed -i 's|app.runtime=$ROOTDIR/lib/runtime|app.runtime=/usr/lib/jvm/default-runtime|' opt/tastyworks/lib/app/tastyworks.cfg
+
+ DF="opt/tastyworks/lib/tastyworks-tastyworks.desktop"
+
+ # Set correct information for the application .desktop launcher
+ sed -i 's|Name=tastyworks|Name=TastyWorks|' $DF
+ sed -i 's|Comment=tastyworks|Comment=Trading Platform|' $DF
+ sed -i 's|Exec=.*|Exec=/usr/bin/tastyworks|' $DF
+ sed -i 's|Icon=.*|Icon=tastyworks|' $DF
+ sed -i 's|Categories=tastyworks|Categories=Network|' $DF
+
+ # Add the correct startup window manager class
+ # This *should* fix gnome from creating more than one dock entry for the program
+ echo 'StartupWMClass=tasty.javafx.launcher.LauncherFxApp' >> $DF
+ sed -i '/^[[:space:]]*$/d' $DF
}
package() {
- # Install program executable
- install -d "$pkgdir/usr/bin"
- install -Dm 755 "$srcdir/opt/$pkgname/bin/$pkgname" "$pkgdir/usr/lib/$pkgname/bin/$pkgname"
- ln -s "/usr/lib/$pkgname/bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -d "${pkgdir}/usr/bin"
+ ln -sf "/usr/lib/${pkgname}/bin/tastyworks" "${pkgdir}/usr/bin/${pkgname}"
- # Install additional program library
- install -Dm 755 "$srcdir/opt/$pkgname/bin/libapplauncher.so" "$pkgdir/usr/lib/$pkgname/bin/libapplauncher.so"
+ install -d "${pkgdir}/usr/lib/${pkgname}/lib/app"
+ cp -r "${srcdir}/opt/tastyworks/lib/app/" "${pkgdir}/usr/lib/${pkgname}/lib/"
+ install -Dm 644 "${srcdir}/opt/tastyworks/lib/libapplauncher.so" "${pkgdir}/usr/lib/${pkgname}/lib/libapplauncher.so"
- # Install application launcher
- install -Dm 644 "$srcdir/opt/$pkgname/bin/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm 755 "${srcdir}/opt/tastyworks/bin/tastyworks" "${pkgdir}/usr/lib/${pkgname}/bin/tastyworks"
- # Install application icon
- install -Dm 644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
-
- # Install necessary Java program jars
- install -d "$pkgname/usr/lib/$pkgname/app"
- cp -r "$srcdir/opt/$pkgname/app/" "$pkgdir/usr/lib/$pkgname/app/"
+ install -Dm 644 "${srcdir}/opt/tastyworks/lib/tastyworks-tastyworks.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm 644 "${srcdir}/opt/tastyworks/share/doc/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/opt/tastyworks/lib/tastyworks.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
}