summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM.Reynolds2019-10-06 18:15:51 -0400
committerM.Reynolds2019-10-06 18:15:51 -0400
commite845b2935e46176497b01f6808bb460553ab3afb (patch)
treeeaf34df66787843a540cebbe3f635614b0b982fd /PKGBUILD
parentebf8f719a147aa854e064881e45b9e8ac020a4ea (diff)
downloadaur-e845b2935e46176497b01f6808bb460553ab3afb.tar.gz
Update 1.0.15-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 23 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 262ae57d9b20..818e1f71ecdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,42 @@
# Maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
pkgname=tastyworks
-pkgver=0.41.0
+pkgver=1.0.15
pkgrel=1
pkgdesc="One of the fastest, most reliable, and most secure trading platforms in the world."
arch=('x86_64')
url="https://tastyworks.com/technology.html"
license=('Other')
depends=('java-runtime')
-source=("https://download.tastyworks.com/desktop/$pkgver/$pkgname-$pkgver.rpm"
+source=("https://download.tastyworks.com/desktop-1.x.x/$pkgver/$pkgname-$pkgver-$pkgrel.x86_64.rpm"
"tastyworks.png")
-sha256sums=('92c06effab44c3af667f7bf6c3f819b2e477a282838ed2ca21d0eaac213d93e0'
+sha256sums=('13cca9c54fe95461a83022b1149dbb6008c20109e805279c2a674872330dad98'
'5875675195bb9156c050976e00c98538a6662740f5359e677d26fe5e21560cea')
-# I'm not sure that the all the lib32 stuff is actually needed. The application seemed to be working
-# fine without it but the "official" install requested those packages. I'll leave them there for
-# now but need to contact tastyworks team for clarification and do some more research.
+package() {
-# I'm removing this list of dependencies because it's clutter and I didn't notice any benefit for
-# having them included. I'll leave it here in a comment in case they're necessary to someone.
+ cd "$srcdir"
-# 'lib32-glibc' 'lib32-gcc-libs'
-# 'lib32-libx11' 'lib32-libxext' 'lib32-libxi'
-# 'lib32-libxtst' 'lib32-libxrender' 'lib32-alsa-lib'
+ find "$srcdir" -name "*.jar" -type f -exec chmod 755 {} \;
+ find "$srcdir" -name "*.so" -type f -exec chmod 755 {} \;
-package() {
+ mkdir -p usr/bin
+
+ pushd "usr/bin" && ln -sf /opt/$pkgname/bin/$pkgname && popd
+
+ install -d "$pkgdir/opt/$pkgname"
+ cp -r "$srcdir/opt/$pkgname/" "$pkgdir/opt/"
+ cp -r "$srcdir/usr/" "$pkgdir/"
- cd "$srcdir"
+ sed -i 's|Name=tastyworks|Name=TastyWorks|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
+ sed -i 's|Comment=tastyworks|Comment=Trading Platform|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
+ sed -i 's|Icon=/opt/tastyworks/tastyworks.png|Icon=tastyworks|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
+ sed -i 's|Categories=Unknown|Categories=Internet|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
- install -d "$pkgdir/opt/$pkgname"
- cp -r "$srcdir/opt/$pkgname/" "$pkgdir/opt/"
+ install -Dm 644 "$srcdir/opt/$pkgname/bin/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- sed -i 's|Name=tastyworks|Name=TastyWorks|' "$srcdir/opt/$pkgname/$pkgname.desktop"
- sed -i 's|Comment=tastyworks|Comment=Trading Platform|' "$srcdir/opt/$pkgname/$pkgname.desktop"
- sed -i 's|Icon=/opt/tastyworks/tastyworks.png|Icon=tastyworks|' "$srcdir/opt/$pkgname/$pkgname.desktop"
- sed -i 's|Categories=Unknown|Categories=Internet|' "$srcdir/opt/$pkgname/$pkgname.desktop"
+ # Alternative Application Icon
+ install -Dm 644 "$srcdir/opt/$pkgname/bin/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ # install -Dm 644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
- install -Dm 644 "$srcdir/opt/$pkgname/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm 644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
-}
+} \ No newline at end of file