summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2022-01-08 11:14:37 +0300
committerCaleb Maclennan2022-01-08 11:14:37 +0300
commit7df20e42d4a942cb216b957b77343944a0b44831 (patch)
tree4989709ccdac64278056450b3745cb5ad40b51ea /PKGBUILD
parent0718f845aedf6c57e554e1375cd75d0430760a45 (diff)
downloadaur-7df20e42d4a942cb216b957b77343944a0b44831.tar.gz
upgpkg: tau-editor 0.12.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e27d7d0bc355..6fd74e4b2aee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=Tau
pkgname=tau-editor
pkgver=0.12.0
-pkgrel=1
+pkgrel=2
pkgdesc='GTK frontend for the Xi text editor, written in Rust'
arch=(x86_64 i686 armv7h aarch64)
url="https://gitlab.gnome.org/World/$_pkgname"
@@ -15,7 +15,8 @@ depends=(libhandy0
makedepends=(meson
rust)
_archive="${_pkgname,,}-$pkgver"
-source=("$url/uploads/b5f24cd692ec0c2a2c2be460fffaf505/$_archive.tar.xz")
+_uploadhash=14037a7f98f475d2497b74bd74a0430e
+source=("$url/uploads/$_uploadhash/$_archive.tar.xz")
sha256sums=('a14e4c3511fa51cc051c33ad04a3989b93c6aa2405e8b0f5ac05970fe5d95449')
prepare() {
@@ -24,10 +25,10 @@ prepare() {
}
build() {
+ # -Dxi-core=system \
+ # -Dlibhandy=enabled \
arch-meson \
- -Dxi-core=system \
- -Dlibhandy=enabled \
- "$_archive" build
+ "$_archive" build
meson compile -C build
}