summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTaiko2k2019-11-18 15:06:14 +1300
committerTaiko2k2019-11-18 15:06:14 +1300
commitb5b1aab91beebb1d477b436cebe450dd1e4c99dc (patch)
tree990ec3e8f8dce204b9f46d8f05d1557043dccbb0 /PKGBUILD
parent2154557c22c2c2688dc3acbc1ed7a554964b949c (diff)
downloadaur-b5b1aab91beebb1d477b436cebe450dd1e4c99dc.tar.gz
update for v5.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e2e2f519042..cbf16eb71605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Maintainer: Taiko2k <captain dot gxj at gmail dot com>
pkgname='tauon-music-box'
-pkgdesc='A streamlined music player that uses BASS'
+pkgdesc='A modern streamlined music player'
url="https://github.com/taiko2k/tauonmb"
-arch=('x86_64')
-license=('custom')
+arch=('any')
+license=('GPL3')
-pkgver=5.0.4
+pkgver=5.1.0
pkgrel=1
-depends=('python3' 'noto-fonts' 'noto-fonts-emoji' 'noto-fonts-extra' 'sdl2_image' 'python-pillow' 'python-pylast' 'python-gobject' 'xdg-utils' 'python-beautifulsoup4' 'python-requests' 'python-cairo' 'python-stagger' 'python-hsaudiotag3k' 'python-flask' 'python-setproctitle' 'flac' 'python-musicbrainzngs' 'python-discogs-client' 'alsa-plugins')
+depends=('python3' 'noto-fonts' 'noto-fonts-emoji' 'noto-fonts-extra' 'sdl2_image' 'python-pillow' 'python-pylast' 'python-gobject' 'xdg-utils' 'python-beautifulsoup4' 'python-requests' 'python-cairo' 'python-stagger' 'python-hsaudiotag3k' 'python-flask' 'python-setproctitle' 'flac' 'python-musicbrainzngs' 'python-discogs-client' 'alsa-plugins' 'gstreamer' 'gst-plugins-base')
-optdepends=('ffmpeg: File transcoding' 'noto-fonts-cjk: Matching font for CJK characters' 'p7zip: 7z archive extraction support' 'unrar: RAR archive extraction support' 'python-plexapi: PLEX client streaming' 'picard: Tag editing')
+optdepends=('ffmpeg: File transcoding' 'noto-fonts-cjk: Matching font for CJK characters' 'p7zip: 7z archive extraction support' 'unrar: RAR archive extraction support' 'python-plexapi: PLEX client streaming' 'picard: Tag editing' 'gst-plugins-good: Extra GStreamer codecs' 'gst-plugins-bad: Extra GStreamer codecs' 'gst-plugins-ugly: Extra GStreamer codecs')
-source=('https://github.com/Taiko2k/tauonmb/releases/download/v5.0.4/Tauon.Music.Box.v5.0.4.Linux.Bass.64bit.zip')
+source=('https://github.com/Taiko2k/tauonmb/releases/download/v5.1.0/Tauon.Music.Box.v5.1.0.Linux.zip')
-sha1sums=('64f548b1c807767d533faca1eed154ca97f8a9e7')
+sha1sums=('ef382a1b4c6811204d7083df41442bb86d53d724')
package() {
@@ -25,7 +25,6 @@ package() {
install -D -m755 "$srcdir/$pkgname/extra/tauonmb.desktop" "$pkgdir/usr/share/applications/tauonmb.desktop"
install -D -m755 "$srcdir/$pkgname/extra/tauonmb-symbolic.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/tauonmb-symbolic.svg"
install -D -m755 "$srcdir/$pkgname/extra/tauonmb.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/tauonmb.svg"
- install -D -m644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cp -R "$srcdir/$pkgname/" "$pkgdir/opt/$pkgname"
}