summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorblooser2019-01-30 17:40:02 +0100
committerblooser2019-01-30 17:40:02 +0100
commit41cedf07e7c84ae71abdeb13f1b003470135f1a5 (patch)
tree0a146f830960e7d2fbae70c420f6d8a7e9c761d4 /PKGBUILD
parent08fb264bee4c48ee3b8542fc62b5986a119f4062 (diff)
downloadaur-41cedf07e7c84ae71abdeb13f1b003470135f1a5.tar.gz
Update program paths
Signed-off-by: blooser <Blooser@protonmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2488312890a0..5d2957b3933b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Blooser <blooser@protonmail.com>
pkgname=taurus
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="GUI port scanner"
arch=('x86_64')
md5sums=('0681ec14f699d55ccc052d4c958945fc')
@@ -9,15 +9,16 @@ url="https://github.com/blooser/taurus"
license=('MIT')
depends=('qt5-base')
makedepends=('cmake')
-applocation=~/.local/share/$pkgname
+binlocation=/usr/bin
+resourcelocation=/usr/share/taurus
shortcut="
[Desktop Entry]
Encoding=UTF-8
Version=${pkgver}
Name[en_US]=Taurus
GenericName=GUI Port Scanner
-Exec=${applocation}/taurus
-Icon[en_US]=${applocation}/discover.png
+Exec=${binlocation}/taurus
+Icon[en_US]=${resourcelocation}/discover.png
Type=Application
Categories=Application;Network
Comment[en_US]=Quick ports scan
@@ -34,15 +35,14 @@ build() {
package() {
cd $pkgname-$pkgver
make clean
- mkdir -p ${applocation} && cp taurus ${applocation}
- cp icons/discover.png ${applocation}
+ sudo cp taurus ${binlocation} && sudo mkdir -p ${resourcelocation} && sudo cp icons/discover.png ${resourcelocation}
cd ..
rm -rf $pkgname-$pkgver
echo "${shortcut}" > ~/.local/share/applications/taurus.desktop
if [ -f ~/.zshrc ]; then
- echo "alias taurus=${applocation}/taurus" >> ~/.zshrc
+ echo "alias taurus=${binlocation}/taurus" >> ~/.zshrc
else
- echo "alias taurus=${applocation}/taurus" >> ~/.bashrc
+ echo "alias taurus=${binlocation}/taurus" >> ~/.bashrc
fi
}