summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorblooser2019-01-11 20:31:15 +0100
committerblooser2019-01-11 20:31:15 +0100
commite87388fb2c753865b6ec77170499161b4e8846a2 (patch)
tree8d2607c28a15ef79ab66a9fc78ac855d90f7e6aa /PKGBUILD
parent4d6fc6bfac87db029f31f19c770cc8db4e3375ed (diff)
downloadaur-e87388fb2c753865b6ec77170499161b4e8846a2.tar.gz
Create applications dir if doesn't exist
Signed-off-by: blooser <Blooser@protonmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbf51affc7ed..1963e2a84b46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Blooser <blooser@protonmail.com>
pkgname=taurus
pkgver=1.2
-pkgrel=2
+pkgrel=3
pkgdesc="GUI port scanner"
arch=('x86_64')
md5sums=('956971bed1cdb1953bd6344162177804')
@@ -38,10 +38,12 @@ package() {
mv $pkgname-$pkgver $pkgname
cp -r $pkgname ~/Documents
rm -rf $pkgname
+ if [ ! -f ~/.local/share/applications ]; then
+ mkdir ~/.local/share/applications
+ fi
echo "${shortcut}" > ~/.local/share/applications/taurus.desktop
if [ -f ~/.zshrc ]; then
echo "alias taurus=${applocation}/taurus" >> ~/.zshrc
-
else
echo "alias taurus=${applocation}/taurus" >> ~/.bashrc
fi