summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLorens Gwine2017-11-30 12:50:08 +0500
committerLorens Gwine2017-11-30 12:50:08 +0500
commit80e624141f4520f1be76a13ef8c21eebec14ba66 (patch)
tree909c9e36d2ca6b27a289bc9264369ad44a13d6cd /PKGBUILD
parentcad5ffe48e74e6c5565bf46bb79e87fabd8f06c1 (diff)
downloadaur-80e624141f4520f1be76a13ef8c21eebec14ba66.tar.gz
add icons and .desktop
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28ef85866634..3fcc09ab4ffd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,9 @@ license=('custom')
provides=($_pkgname)
conflicts=($_pkgname)
makedepends=('git' 'npm')
-source=("$pkgname::git+https://github.com/mccxiv/tc.git")
-md5sums=('SKIP')
+source=("$_pkgname.desktop" "$pkgname::git+https://github.com/mccxiv/tc.git")
+md5sums=('72e3fe4d7076cd6e7c26d5d3819b1c0a'
+ 'SKIP')
pkgver() {
cd $pkgname
@@ -38,5 +39,9 @@ package() {
install -d "$pkgdir"/{usr/bin,opt}
cp -a $srcdir/$pkgname/dist/linux-unpacked $pkgdir/opt/$_pkgname
ln -s $pkgdit/opt/$_pkgname/Tc $pkgdir/usr/bin/tc-twitch
- install -Dm644 $srcdir/$pkgname/LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+ install -Dm644 $srcdir/$_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
+ install -Dm644 $srcdir/$pkgname/LICENSE $pkgdir/usr/share/licenses/$_pkgname/LICENSE
+ # icons
+ install -Dm644 $srcdir/$pkgname/src/assets/icon16.png $pkgdir/usr/share/icons/hicolor/16x16/apps/$_pkgname.png
+ install -Dm644 $srcdir/$pkgname/src/assets/icon256.png $pkgdir/usr/share/icons/hicolor/256x256/apps/$_pkgname.png
}