summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2015-06-20 19:54:52 +0200
committerGrey Christoforo2015-06-20 19:54:52 +0200
commita2a0d080d045f170fbf301b5d49c85548589421f (patch)
tree5c6dfbc03e422a3cf15815219a39675a9f98a415 /PKGBUILD
downloadaur-tcl-cookfs.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b40f12bf842
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=tcl-cookfs
+pkgver=1.4
+pkgrel=4
+pkgdesc="cookfs file system for tcl"
+arch=('i686' 'x86_64')
+url="http://www.endorser.org/en/blog/tcl/cookfs"
+license=('custom')
+depends=(tcl tcl-vfs tcllib)
+makedepends=(tcl)
+source=(https://github.com/l3iggs/${pkgname}/archive/${pkgver}.tar.gz)
+md5sums=('4e9c8c2a49a0499207911bdca0801df9')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 license.terms "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}