summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortequa2015-11-18 19:59:12 +0100
committertequa2015-11-18 19:59:12 +0100
commit54db13189a34a1a6ccf3d7a09aa75eb66c4a4dfa (patch)
treec161b0bce1ff8112ec0bfd5b8ea76b68726147ed /PKGBUILD
downloadaur-54db13189a34a1a6ccf3d7a09aa75eb66c4a4dfa.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fa91bce5268
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=tclln
+pkgver=0.9
+pkgrel=1
+pkgdesc="TclLN is a library for integrating a tcl-shell with custom commands"
+url="https://github.com/TestudoAquatilis/tclln"
+arch=('x86_64' 'i686' 'armv7h')
+license=('LGPLv3')
+depends=('tcl' 'glib2')
+optdepends=()
+makedepends=('git' 'gcc' 'make')
+conflicts=()
+replaces=()
+backup=()
+#install='foo.install'
+source=("git+https://github.com/TestudoAquatilis/tclln.git")
+md5sums=('SKIP')
+
+build () {
+ cd "${pkgname}"
+ make lib
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm744 libtclln.so "$pkgdir/usr/lib/libtclln.so"
+ install -Dm644 tclln.pc "$pkgdir/usr/lib/pkgconfig/tclln.pc"
+ install -Dm644 tclln.h "$pkgdir/usr/include/tclln.h"
+}
+
+# vim:set ts=2 sw=2 et: