summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChongChengAC2023-04-01 08:38:43 +0800
committerChongChengAC2023-04-01 08:38:43 +0800
commit57cdb54576939f344ff3a18edb2eafe93975f7d7 (patch)
tree730d64fc00a51b126a88b220bc4bcc38f50cc659 /PKGBUILD
downloadaur-57cdb54576939f344ff3a18edb2eafe93975f7d7.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c0b2f69f448
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: ChongChengAC <408173145@qq.com>
+pkgname=tcping-go-bin
+_pkgname=tcping_Linux
+pkgver=1.19.1
+pkgrel=1
+pkgdesc="Ping TCP ports. Inspired by Linux's ping utility. Written in Go"
+arch=('x86_64')
+url="https://github.com/pouriyajamshidi/tcping"
+license=('MIT')
+depends=('glibc')
+provides=('tcping' 'tcping-go')
+conflicts=('tcping' 'tcping-go-git')
+source=("https://github.com/pouriyajamshidi/tcping/releases/download/v$pkgver/$_pkgname.tar.gz")
+sha256sums=('7d943042ef586b860519496fa566341efafc0fd32ef4abbabd5db42c6081eac8') #autofill using updpkgsums
+
+build() {
+ tar xvf $_pkgname.tar.gz
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ install tcping $pkgdir/usr/bin/
+}