summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTilo Brueckner2017-06-25 13:16:52 +0200
committerTilo Brueckner2017-06-25 13:16:52 +0200
commit360baec21d6d948d11ebc4d5df33e2e69e0e4f86 (patch)
tree9d9869f4cbced0b0dfb10ccb12f50c57a15cb59b /PKGBUILD
parent215f4e2b99cafc7694efced6fa359e552919318c (diff)
downloadaur-360baec21d6d948d11ebc4d5df33e2e69e0e4f86.tar.gz
Bumped to version 1.3.4.1678
- disabled not working UpdateChecker - additional upstream patches
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ca9c8c4a1b5..a2c0ee6b4e4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,39 @@
_pkgname=RP-Soundboard
pkgname=teamspeak3-plugin-rp-soundboard
-pkgver=1.3.3.1622
-pkgrel=2
+pkgver=1.3.4.1678
+pkgrel=1
pkgdesc='Plugin for Teamspeak 3. Easy to use soundboard'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/MGraefe/${_pkgname}"
license=('Unknown')
-makedepends=('teamspeak3-pluginsdk>=3.1.0.1' 'qt5.6')
+makedepends=('teamspeak3-pluginsdk>=3.1.0.1' 'qt5.6' 'python')
depends=('teamspeak3>=3.1.0.1')
source=("https://github.com/MGraefe/${_pkgname}/archive/${pkgver}.tar.gz"
+ '0001-Fixed-linux-compilation.patch::https://github.com/MGraefe/RP-Soundboard/commit/187aaf35b00debdd29a980765df3b64fd17354dd.patch'
+ '0002-Fixed-refactoring-error.patch::https://github.com/MGraefe/RP-Soundboard/commit/0e503743b7db748ecd63d53fce80469b75ee2c54.patch'
+ '0003-Fixed-potential-memory-leaks.patch::https://github.com/MGraefe/RP-Soundboard/commit/fc07edb336aae5a3f3c79572a186c7b65045aa56.patch'
'build-fixes.patch')
-sha256sums=('1f7cb5436ec0a0bb61b5bfc1589412774717561e0ad1509dade419bfc1e5d5f4'
- 'd23d2c5d4cc58d21593b42a5a85e207021fb4a98085fe73a29d05619fc78833b')
-
+sha256sums=('71a6484cf58a5bfea23258d71327256001ac942e55ab44ddea786580a864b7ed'
+ '550ff571a032528bcd934258a3b051a740153c16d10151fde3fc8692e0c22600'
+ 'de2fafb177346d1f0f077f634e8e603730651c651a03947bd9bda5ae54386f8e'
+ '5b276b78c55e489be85616e2a0a0c567bc667fe6f6b78b1c3bc093a9abe637e0'
+ '0341a960209a2b64dddcbb417d3976d6415e41d4f4e61c43a7f372e175327a53')
prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/0001-Fixed-linux-compilation.patch"
+ patch -p1 -i "${srcdir}/0002-Fixed-refactoring-error.patch"
+ patch -p1 -i "${srcdir}/0003-Fixed-potential-memory-leaks.patch"
patch -p0 -i "${srcdir}/build-fixes.patch"
+
cd src/version
python version.py
}
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}/qt-linux"
+ cd "${_pkgname}-${pkgver}/qt-linux"
export TS3DIR=/opt/teamspeak3
/opt/qt5.6/bin/qmake ts3soundboard_linux.pro
@@ -34,7 +43,7 @@ build() {
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
mkdir -pm0755 ${pkgdir} "$pkgdir/opt/teamspeak3/plugins"
install -D -m644 bin/release_lin/librp_soundboard.so "$pkgdir/opt/teamspeak3/plugins/librp_soundboard.so"