summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2018-04-04 10:43:30 +0200
committerSebastian 'Swift Geek' Grzywna2018-04-04 10:53:47 +0200
commit7fd0502da3db31e98d1b03b789a9571fe4ab5060 (patch)
tree664fad4adb0a525cda7afbebf33b3932f7fc91ef /PKGBUILD
parentff06caf63e81a6ddc935c536ec6c430335057971 (diff)
downloadaur-7fd0502da3db31e98d1b03b789a9571fe4ab5060.tar.gz
Bump to 13.1.3026, add host 13.1.1548 for armv7h as workaround
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 28 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1d6ccb5f26f..40bdb2f73999 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,50 @@
# Maintainer: Alex Taber <aft dot pokemon at gmail dot com>
pkgname=teamviewer
-pkgver=12.0.90041
-pkgrel=7
+pkgver=13.1.3026
+pkgrel=9
pkgdesc='All-In-One Software for Remote Support and Online Meetings'
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h')
url='http://www.teamviewer.com'
license=('custom')
options=('!strip')
provides=('teamviewer')
conflicts=('teamviewer-beta')
depends_x86_64=(
- 'lib32-fontconfig'
+ 'hicolor-icon-theme'
+ 'qt5-webkit'
+ 'qt5-x11extras'
+ 'lib32-libxtst'
'lib32-libpng12'
- 'lib32-libsm'
- 'lib32-libxinerama'
- 'lib32-libxrender'
'lib32-libjpeg6-turbo'
- 'lib32-libxtst'
- 'lib32-freetype2'
- 'lib32-dbus'
- 'libxtst')
+ 'lib32-libxinerama'
+ 'lib32-qt4')
depends_i686=(
- 'fontconfig'
+ 'hicolor-icon-theme'
+ 'qt5-webkit'
+ 'qt5-x11extras'
+ 'libxtst'
'libpng12'
- 'libsm'
- 'libxinerama'
- 'libxrender'
'libjpeg6-turbo'
- 'freetype2'
- 'libxtst')
+ 'libxinerama'
+ 'qt4')
+depends_armv7h=(${depends_i686[*]})
install=teamviewer.install
-source_x86_64=("https://download.teamviewer.com/download/version_${pkgver%%.*}x/teamviewer_${pkgver}_amd64.deb"
- "https://archive.archlinux.org/packages/l/lib32-freetype2/lib32-freetype2-2.8-2-x86_64.pkg.tar.xz")
-source_i686=("https://download.teamviewer.com/download/version_${pkgver%%.*}x/teamviewer_${pkgver}_i386.deb"
- "https://archive.archlinux.org/packages/f/freetype2/freetype2-2.8-2-i686.pkg.tar.xz")
-sha256sums_i686=('8f2f108d2e303705a55111fd8af6561f25537b017bcc795766d6aba63a32eea5'
- 'd33cf8be0c4be1c602d368fb363c9029d87f2bc4fdfcae5063595ac482ca39e8')
-sha256sums_x86_64=('a30bfaa0ddfa7f6ab03141f0deb8fd0a26760e1b18ea1cb9e54b5b54bf2c0131'
- '4f39c9bd52579ac5d13980d760a5434fdb0f0638df07d2abca9ea44a779185e3')
+source_x86_64=("https://dl.tvcdn.de/download/linux/version_${pkgver%%.*}x/teamviewer_${pkgver}_amd64.deb")
+source_i686=("https://dl.tvcdn.de/download/linux/version_${pkgver%%.*}x/teamviewer_${pkgver}_i386.deb")
+#source_armv7h=("https://dl.tvcdn.de/download/linux/version_${pkgver%%.*}x/teamviewer_${pkgver}_armhf.deb")
+source_armv7h=("https://dl.tvcdn.de/download/linux/version_${pkgver%%.*}x/teamviewer-host_13.1.1548_armhf.deb")
+sha256sums_i686=('46f1b697a113f304ff8e5792f9893319c0de6b802355e7e5fdf7dba6f4b415c8')
+sha256sums_x86_64=('33eacc8ebeaf34aea5fa932e3d80553f358629ad454740f05aafba267b50ea93')
+sha256sums_armv7h=('d887c4faae3b85542e982dbb8add5271fdeb1da98c669b230d82dd56e04724bf')
prepare() {
warning "If the install fails, you need to uninstall previous major version of Teamviewer"
- mkdir data
- cd data
+ [ -d data ] && rm -rf data
+ mkdir data
+ cd data
tar -xf ../data.tar.bz2
+ tar -xf ../data.tar.xz
}
package() {
@@ -52,12 +52,9 @@ package() {
warning "If the install fails, you need to uninstall previous major version of Teamviewer"
cp -dr --no-preserve=ownership ./data/{etc,opt,usr,var} "${pkgdir}"/
- # freetype workaround
- [ -e "${srcdir}/usr/lib32/libfreetype.so.6.14.0" ] && install -D -m0755 "${srcdir}/usr/lib32/libfreetype.so.6.14.0" "${pkgdir}/opt/teamviewer/tv_bin/wine/lib/libfreetype.so.6"
- [ -e "${srcdir}/usr/lib/libfreetype.so.6.14.0" ] && install -D -m0755 "${srcdir}/usr/lib/libfreetype.so.6.14.0" "${pkgdir}/opt/teamviewer/tv_bin/wine/lib/libfreetype.so.6"
-
# Additional files
rm "${pkgdir}"/opt/teamviewer/tv_bin/xdg-utils/xdg-email
+ rm -rf "${pkgdir}"/etc/apt
install -D -m0644 "${pkgdir}"/opt/teamviewer/tv_bin/script/teamviewerd.service \
"${pkgdir}"/usr/lib/systemd/system/teamviewerd.service
install -d -m0755 "${pkgdir}"/usr/{share/applications,share/licenses/teamviewer}