summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTiago de Paula2024-04-21 16:04:04 -0300
committerTiago de Paula2024-04-22 21:35:35 -0300
commit400d23d575bcb0bdbc014a86964b7881bec90aec (patch)
tree59764d26d21c3eaf37ee874b69a9689100b72246 /PKGBUILD
parentab06d97161f13fd50d550103c94decfde8862c8f (diff)
downloadaur-400d23d575bcb0bdbc014a86964b7881bec90aec.tar.gz
fix: package dependencies
A few details here: - 'bash' is already required by pacman and makepkg, we don't need to declare it - 'gtk-update-icon-cache' shouldn't be used at all, better leave it to the pacman hook - 'adwaita-icon-theme' and 'breeze-icons' are declared in the 'Inherits' section of 'index.theme'
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 147ab820fd63..1ee3b5cfea86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,10 @@ pkgrel=1
url="https://github.com/vinceliuice/${_pkgbase^}"
arch=('any')
license=('GPL3')
-makedepends=('bash' 'git')
-depends=('gtk-update-icon-cache' 'hicolor-icon-theme')
+makedepends=('git')
+depends=('hicolor-icon-theme')
+optdepends=('adwaita-icon-theme: for better GNOME integration'
+ 'breeze-icons: for better KDE integration')
provides=("${_pkgbase}")
options=(!strip !debug)
source=("${_pkgbase}::git+${url}.git")
@@ -24,6 +26,15 @@ pkgver() {
}
_package() {
+ # The icon cache is generated by a pacman hook, so it can be regenerated when 'gtk-update-icon-cache' is updated,
+ # and shouldn't be part of the package itself. Other icon packages like 'hicolor-icon-theme' and 'adwaita-icon-theme'
+ # does things this way.
+ # See https://gitlab.archlinux.org/archlinux/packaging/packages/gtk4/-/blob/main/gtk-update-icon-cache.hook
+ gtk-update-icon-cache() {
+ true
+ }
+ export -f gtk-update-icon-cache
+
cd "${_pkgbase}"
install -dm755 "${pkgdir}/usr/share/icons"
./install.sh -d "${pkgdir}/usr/share/icons" ${1}