summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTiago de Paula2024-04-21 16:09:52 -0300
committerTiago de Paula2024-04-22 21:35:36 -0300
commita8edb049782daef80a198fde88b9d11c5fa2dcc8 (patch)
tree45b2e4e83bc72619390fb30577d2e25a7b01e599 /PKGBUILD
parent400d23d575bcb0bdbc014a86964b7881bec90aec (diff)
downloadaur-a8edb049782daef80a198fde88b9d11c5fa2dcc8.tar.gz
feat: tela-circle-icon-theme-all as a meta package
Currently, this PKGBUILD forces any user to build every theme twice, when each theme will be installed only once, or maybe never. This change makes 'tela-circle-icon-theme-all' into a non-build package, avoiding repeated builds, and effectively reducing makepkg time and BUILDDIR size in half.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ee3b5cfea86..ce4f942c5798 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,6 +25,12 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+package_tela-circle-icon-theme-all-git() {
+ pkgdesc="${pkgdesc} (all variants)"
+ depends=(${_pkgname[@]/%/-git})
+ conflicts=(${_pkgbase}-all)
+}
+
_package() {
# The icon cache is generated by a pacman hook, so it can be regenerated when 'gtk-update-icon-cache' is updated,
# and shouldn't be part of the package itself. Other icon packages like 'hicolor-icon-theme' and 'adwaita-icon-theme'
@@ -37,14 +43,7 @@ _package() {
cd "${_pkgbase}"
install -dm755 "${pkgdir}/usr/share/icons"
- ./install.sh -d "${pkgdir}/usr/share/icons" ${1}
-}
-
-package_tela-circle-icon-theme-all-git() {
- pkgdesc="${pkgdesc} (all variants)"
- conflicts=("${_pkgbase}" "${_pkgbase}"-all)
-
- _package -a
+ ./install.sh -d "${pkgdir}/usr/share/icons" "${1}"
}
for _theme in "${_themes[@]}"; do