summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTiago de Paula2024-04-21 16:01:52 -0300
committerTiago de Paula2024-04-22 21:13:44 -0300
commitab06d97161f13fd50d550103c94decfde8862c8f (patch)
treec6575e8a9c088564caaaeb39a004ea1322ff794b /PKGBUILD
parent84b88930cdc60586184fc663e13904c9144b7525 (diff)
downloadaur-ab06d97161f13fd50d550103c94decfde8862c8f.tar.gz
fix: internal conflict declaration
We don't need to specify that '*-git' package conflicts with themselves, just its non git version. For the '*-all' package, we don't need to specify a conflict with each theme package. Instead, we specify a conflict with any 'tela-circle-icon-theme' provider, which includes every theme package. Additionally, we don't specify a conflict with '*-all' for each theme package, because the conflict is already specified in the '*-all' package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0633af807ef1..147ab820fd63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ arch=('any')
license=('GPL3')
makedepends=('bash' 'git')
depends=('gtk-update-icon-cache' 'hicolor-icon-theme')
-provides=("${_pkgbase}" "${_pkgbase}-git")
+provides=("${_pkgbase}")
options=(!strip !debug)
source=("${_pkgbase}::git+${url}.git")
b2sums=('SKIP')
@@ -23,26 +23,24 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-package_tela-circle-icon-theme-all-git() {
- pkgdesc="${pkgdesc} (all variants)"
- conflicts=(${pkgname[@]/${pkgbase%-git}-all-git} "${pkgname[@]/%-git/}")
-
+_package() {
cd "${_pkgbase}"
install -dm755 "${pkgdir}/usr/share/icons"
- ./install.sh -a -d "${pkgdir}/usr/share/icons"
+ ./install.sh -d "${pkgdir}/usr/share/icons" ${1}
}
-_package() {
- pkgdesc="${pkgdesc} (${1} variant)"
- conflicts=("${_pkgbase}-all-git" "${_pkgbase}-all" "${_pkgbase}-${1}")
+package_tela-circle-icon-theme-all-git() {
+ pkgdesc="${pkgdesc} (all variants)"
+ conflicts=("${_pkgbase}" "${_pkgbase}"-all)
- cd "${_pkgbase}"
- install -dm755 "${pkgdir}/usr/share/icons"
- ./install.sh -d "${pkgdir}/usr/share/icons" "${1}"
+ _package -a
}
for _theme in "${_themes[@]}"; do
eval "package_${_pkgbase}-${_theme}-git() {
- _package ${_theme}
+ pkgdesc='${pkgdesc} (${_theme} variant)'
+ conflicts=(${_pkgbase}-${_theme})
+
+ _package '${_theme}'
}"
done