summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorqontinuum2021-07-04 10:54:22 +0200
committerqontinuum2021-07-04 10:54:22 +0200
commitb90bfd3c8880a85aca9513375ab11495f04f0a0b (patch)
treeccf1339de0ae85c7d160ceb0853d5e43708af106 /PKGBUILD
parent9efbe83facb9808cf289de6dfc550326f617c5b6 (diff)
downloadaur-b90bfd3c8880a85aca9513375ab11495f04f0a0b.tar.gz
Disable compilation of useless static library and echobot
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8663c70f712a..388f78270c7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,10 @@ url='https://elmurod.net/telebot/'
license=('Apache')
depends=('json-c' 'curl')
makedepends=('cmake')
-source=('git+https://github.com/smartnode/telebot')
-b2sums=('SKIP')
+source=('git+https://github.com/smartnode/telebot'
+ 'patch')
+b2sums=('SKIP'
+ '334d61c9233b80e3f861d1500420beaaf924a80a8c8dae025fc65d6ee9ddcced553add389c6c863d76262b6c5f4b108b7e102699b083384cb504bda069c0f707')
pkgver() {
cd "telebot"
@@ -19,6 +21,7 @@ pkgver() {
prepare() {
cd "$srcdir/telebot"
+ patch --forward --strip=1 --input="$srcdir/patch"
cmake -DCMAKE_INSTALL_PREFIX=/usr .
}