summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSarisan2022-05-10 16:40:22 +0300
committerSarisan2022-05-10 16:40:22 +0300
commitc0d15464bc196815577927f931f3be5f8a312ea6 (patch)
treeb8cd5c28a4f4b5e87e638c274344089b1ea9d5e5 /PKGBUILD
parent70a833fc8abcd3d05f0bc6f4214a0d8ff54722c6 (diff)
downloadaur-c0d15464bc196815577927f931f3be5f8a312ea6.tar.gz
Update version to 6.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a3d2899010a..29eba02a9aac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Sarisan Sekoohaka <sekoohaka.sarisan@gmail.com>
pkgname=telegram-bot-api
-pkgver=6.0.1
+pkgver=6.0.2
pkgrel=1
pkgdesc="Telegram Bot API server"
arch=('x86_64')
url="https://core.telegram.org/bots"
-license=('BSL-1.0')
-depends=('openssl' 'zlib' 'gcc-libs')
-makedepends=('git' 'gcc>=4.9' 'gperf' 'cmake>=3.0.2')
+license=('Boost')
+depends=('gcc-libs' 'openssl' 'zlib')
+makedepends=('cmake>=3.0.2' 'gcc>=4.9.2' 'git' 'gperf')
provides=('telegram-bot-api')
conflicts=('telegram-bot-api-git')
-_commit=0dfcb6153af500277fd9388dac3f10aa01008323
-_commit1=782670c7dbf278e0ba07fc7e168f39ac154c7238
+_commit=8a0f1dd730aa41ab7b792b9ff03d92b1c5022c9f
+_commit1=ab3a8282d4ee307d341071267ef1090b1a941478
source=("git+https://github.com/tdlib/telegram-bot-api.git#commit=$_commit"
"git+https://github.com/tdlib/td.git#commit=$_commit1")
sha256sums=('SKIP'
@@ -26,14 +26,10 @@ prepare() {
}
build() {
- mkdir -p telegram-bot-api/build
- cd telegram-bot-api/build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" ..
- cmake --build .
+ cmake -S telegram-bot-api -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr"
+ cmake --build build
}
package() {
- cd telegram-bot-api/build
- mkdir -p "$pkgdir/usr"
- cmake --build . --target install
+ cmake --build build --target install
}